Engine Not Heating Up Right - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-01-2011, 09:11 AM Thread Starter
Forum Regular
 
10cobalt's Avatar
 
Join Date: Sep 2010
Location: Clinton Twp, MI
Posts: 140
Garage
Engine Not Heating Up Right

i have a 2010 coupe lt, i am not sure if this is a problem or if it is just the balt. but when i warm up my car in the morning it will only heat up to 144 degrees and when i am driving it goes to 180-190. And the heat isn't warm until like 160 or 170. then if i park and leave it idleing because i am sitting in it the temp drops back to 144 and the heat gets cold again. also my car takes like 10 or 15 min of driving to warm up. i was hoping to find out if this is just the balt or if there is something wrong.

drive it like you stole it!

Sig thanks to padlock
10cobalt is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-01-2011, 09:56 AM
Say What again!
YourCobalt of the Month Winner
YourCobalt.com Premium Member


 
MP81's Avatar
 
Join Date: Sep 2009
Location: Washington Township, Michigan
Posts: 5,983
Garage
Maybe your thermostat is sticking.

1986 Chevrolet Camaro IROC-Z - Wrecked/Sold
1998 Chevrolet Cavalier - Wrecked/Donated
2007 Chevrolet Cobalt LT - M62 Supercharger, Ported Throttle Body, 42 lb/hr Injectors, Intense 2.9" Pulley, Cobra Heat Exchanger, SS/TC Exhaust, TTR Engine and Trans Mounts, Trifecta Tune, ZZP Header and Downpipe, '08+ FE5 Struts/Shocks, SSC Springs, FE5 Control Arms, SS/SC Front Swaybar, Powell Hardcore Rear Swaybar, 18" MSR 045s, Dunlop ZIIs, Nightshaded Tails/Side Markers, Shorty Antenna, Black Bowties, Black Grilles, Black Headlights, Dual JL 12" w1v2 Subs, A/D/S Front/Rear Speakers, Pioneer 7" Touchscreen, G85 Recaros, Leather Rear Seats, 160 MPH Cluster.
2014 Chevrolet Cruze Diesel - 17" MSR 013s, Black Bowties, Black Tails, UR Rear Lower Bar
1981 Chevrolet Camaro Z28 - JVC Ribbon Tweeters, SEAS Mids, Pyle Woofers, Kenwood Tape Deck, Zapco Amp/Equilizer, Ceramic-Coated Longtubes, 2.5" Pypes Stainless Exhaust, Bilstein B6 Shocks, GW U/L Control Arms, Hotchkis Springs Sway Bars, DD HDX Cluster
2017 Chevrolet Volt LT - Black Bowties
MP81 is offline  
post #3 of 4 (permalink) Old 02-01-2011, 10:24 AM Thread Starter
Forum Regular
 
10cobalt's Avatar
 
Join Date: Sep 2010
Location: Clinton Twp, MI
Posts: 140
Garage
thats what i thought but i wanted to make sure there was actually a problem and not just the car, and about the seats money fell through so i wont be able to get them sorry dude

drive it like you stole it!

Sig thanks to padlock
10cobalt is offline  
 
post #4 of 4 (permalink) Old 02-01-2011, 11:22 AM
Newcomer
 
U8_mY_g00ch's Avatar
 
Join Date: Feb 2011
Posts: 13
Definitely sounds like your thermostat is stuck open, and make sure the cap on the resevoir is tight and the rubber gasket in there is good.

2007 SS/SC

TVS w/ 2.9", E-85, 80# inj., 3" CAI w/ K&N, ZZP Mid-Length Header, 3" DP w/ High-Flow Magnaflow Cat, 3" Cat-Back w/ Magnaflow, OTTP H/E In-Line w/stock, Option B, NGK One Step Colder Plugs, TTR Engine Mount

U8_mY_g00ch is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome