Idling Problem at Stop/ Deceleration - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-21-2011, 11:02 AM Thread Starter
Newcomer
 
Join Date: Jul 2009
Posts: 21
Unhappy Idling Problem at Stop/ Deceleration

So I have been having this problem for awhile but now since it is getting hotter again it is happening even worse! I have took it to the dealer and car shop before nobody knows what it is its getting annoying. My car is not that old a 2009 with only 64,000 miles.

I have changed the fallowing to be new in the last 5,000 miles and still see this problem:
Throttle Body
Map sensor
Spark Plugs
Fuel Filter
Air Filter
Cabin Filter

But the car now stalls again after it has been running for at least 30 minutes and while at idle its the worst a a stoplight and occasionally while at cruising speed. We took the car to a friends shop that is a certified AcDelco shop to service Chevy and GM cars. It stumbled while there on his state of the art engine analyzer and it triggered no soft or hard codes so it is a mechanical problem inside the motor or a problem with the computer. We think it could be the idle control valve, timing chain, actual timing of the motor, or the ecu. All of which are covered under the warranty of the motor on the car. What do yall think? From searching these problems tend to be common has anyone else has this issue. I'm just getting old of this been happening since October.
rock_drummer08 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome