Rear Turn Signal Doesn't Work, but the Light Does - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-27-2011, 06:46 PM Thread Starter
Contributor
 
zimzim's Avatar
 
Join Date: Mar 2010
Posts: 252
Garage
Rear Turn Signal Doesn't Work, but the Light Does

Basically, my rear passenger turn signal won't turn on, but when the lights are on the tail light lights up. I am unsure about the brake light, since i can't activate it and look at the light at the same time. Will investigate tonight with a multimeter tonight, but has anyone had a similar problem?>

---------- Post added at 07:46 PM ---------- Previous post was at 06:11 PM ----------

So, after investigation, our tail lamps are dual filament bulbs, so only one filament burnt out. Replaced the bulb and its all good.
zimzim is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-27-2011, 07:34 PM
423
Cobalt Specialist
 
423's Avatar
 
Join Date: Oct 2007
Location: Kilmarnock, VA
Posts: 1,060
Rear bulb.... it's a dual filament. Replace with oem part number.
And check front bulb on same side for correct operation.

423


If You're SCARED... SAY You're SCARED...
423 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome