LAP Engine Whistle - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-08-2011, 05:48 AM Thread Starter
Contributor
 
Cliff's Avatar
 
Join Date: Aug 2010
Posts: 435
LAP Engine Whistle

For the past week I keep hearing a whistle noise when either accelerating or revving. I've checked the airbox much as I can but looks tight. Not to mention it's raining too hard to look at it further. Any ideas

2010 Cobalt 2LT Victory red Coupe
Mods: Tinted 50% ceramic all around, factory spoiler, 2008 LE5 2.4 Throttle body, GMPP Intake, Walker stock exhaust system (back to silence), TruBendz/MBE 2.5" catted Downpipe, HP Tuners by Chenry Motorsports, Alpine CDE-151 with USB port, Rockford Fosgate 300-10
Cliff is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-08-2011, 03:57 PM
Forum Regular
 
Join Date: Jan 2011
Location: Nova Scotia, Canada
Posts: 73
Mine does that on occasion, I really only notice it if I don't have the radio on.
SummitWhite is offline  
post #3 of 5 (permalink) Old 07-08-2011, 06:25 PM
Veteran
 
GpB311's Avatar
 
Join Date: Jun 2010
Location: Los Angeles, CA
Posts: 713
Garage
Im not sure if its related in any way, but ever since I put a 2.4IM on my 2.2, it whistles during acceleration. Every gasket is perfect, ive taken it off and tried new ones and proper torque and it never goes away. Got even stronger when I added my injen intake.

GpB311 Showoff Profile https://www.yourcobalt.com/forums/veh...ngeles-ca.html


You might also know me as Dick Thrusthumper...
GpB311 is offline  
 
post #4 of 5 (permalink) Old 07-09-2011, 07:58 AM
Veteran
 
bluecobaltls's Avatar
 
Join Date: Sep 2009
Location: maryland
Posts: 745
Garage
same problem lol. i have airboxmod and 2.4 manifold. when i get high rpm it sounds like all you can hear is air sucking

<img src=http://i51.tinypic.com/154yqon.jpg border=0 alt= />
bluecobaltls is offline  
post #5 of 5 (permalink) Old 07-13-2011, 08:27 PM
Cobalt Specialist
 
Join Date: Oct 2006
Location: New York
Posts: 1,388
Send a message via AIM to Chester
Check all your vaccumn lines. Make sure none are torn, dryrotted, disconnected and tight. I had one on mine that was torn on the bottom side coming from the PCV hose going to the top of the valve cover. Also take a can of throttle body cleaner and spray it around the area of where you hear the sound coming from. If the motor studders or hesitates then this will give you a good idea of where the effected area is at.



Mod's So Far: AEM CAI, C.A. Header, 2.50 Magnaflow Catback Exhaust , ZZP Catless Downpipe, DC Carbon Strut Bar, Dropped on Progress Springs. Tinted, Fully Debadged, Custom front SS bumper,2 Audiobahn 10" w/JL amp, Lower Billett Grille, Sengen 18 x 8 rims wrapped in Capitol Sport UHP 225/40/18.

Chester is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome