Car Wont Turn on but Battery Resets - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-17-2011, 11:51 AM Thread Starter
Forum Regular
 
baines888's Avatar
 
Join Date: Jun 2010
Location: maine
Posts: 179
Garage
Car Wont Turn on but Battery Resets

Its happened twice now, my car wont turn over but when i turn the key into th0e on position, the batter resets (i know this because my radio resets)....
I noticed today that the plastic door cover to my pos post was open...so i dont know if something in the trunk kept shorting it out or what, or is this another famous cobalt problem....

Also, to get it started ive been opening the hood and pressing on the maf sensor....pressing it tighter onto its adapter....once i close the hood the car wilk start...so i dont know whats happening...

baines888 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-17-2011, 12:19 PM
Staff Alumni
YourCobalt.com Premium Member


 
scagnetti76's Avatar
 
Join Date: Feb 2009
Location: Helena Mt
Posts: 3,700
Garage
not a problem ive heard of before. i would think if there was a problem with the maf you would have a cel.
scagnetti76 is offline  
post #3 of 6 (permalink) Old 08-17-2011, 04:18 PM
Expert
 
Join Date: Apr 2011
Posts: 985
Garage
sounds like a loose connection somewhere. not sure why the MAF would make a difference with it starting.
acoutu is offline  
 
post #4 of 6 (permalink) Old 08-18-2011, 05:15 AM
Newcomer
 
Join Date: Nov 2010
Posts: 13
Quote:
Originally Posted by baines888 View Post
Its happened twice now, my car wont turn over but when i turn the key into th0e on position, the batter resets (i know this because my radio resets)....
I noticed today that the plastic door cover to my pos post was open...so i dont know if something in the trunk kept shorting it out or what, or is this another famous cobalt problem....

Also, to get it started ive been opening the hood and pressing on the maf sensor....pressing it tighter onto its adapter....once i close the hood the car wilk start...so i dont know whats happening...
I have to second that motion that the MAF sensor won't cause the engine not to turn over. Sounds to me there is a short somewhere from the battery/starter relay/starter to cause it not to turn over. Just my opinion.
curryjl is offline  
post #5 of 6 (permalink) Old 08-18-2011, 05:13 PM
Contributor
 
LT1R's Avatar
 
Join Date: Oct 2009
Location: sugar grove ohio
Posts: 429
thats a weird problem,never seen it before,but i agree with above statements that it sounds like a short,and it might not hurt to check all fusess to be sure
LT1R is offline  
post #6 of 6 (permalink) Old 08-19-2011, 09:03 AM
Contributor
 
zimzim's Avatar
 
Join Date: Mar 2010
Posts: 252
Garage
Have the same problem. Have not found a solution yet. It may be that after it rains water gets into the fuse box.
zimzim is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome