2.4 Engine into a 2009 LT Cobalt - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-07-2011, 12:04 PM Thread Starter
Newcomer
 
Join Date: Dec 2010
Posts: 1
2.4 Engine into a 2009 LT Cobalt

I have a 2009 LT Cobalt with 2.2L engine that was overheated. The mechanic replaced it with a 2.4L engine. He said he used the 2.2 manifolds on the replacement engine. It ran unevenly until I unplugged the varible valve sensors. That appeared to take care of most of the problem except it is now hard to start. Is there a way to make this 2.4 engine work properly in this car; such as changing the head or the electronic engine controls? The dealership said this engine would not work.
redbird is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-07-2011, 12:58 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
They ****ed you over. They should've just fixed whatever problem it was that made it overheat. I would bring it back to get your engine fixed or sue them for ****ing your car up

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #3 of 8 (permalink) Old 09-07-2011, 01:24 PM
Veteran
 
GpB311's Avatar
 
Join Date: Jun 2010
Location: Los Angeles, CA
Posts: 713
Garage
Took you a long time to make your first post and its a doozy...

So the mechanic just said "derp derp, 2.4 is close enough to 2.2"?

GpB311 Showoff Profile https://www.yourcobalt.com/forums/veh...ngeles-ca.html


You might also know me as Dick Thrusthumper...
GpB311 is offline  
 
post #4 of 8 (permalink) Old 09-07-2011, 02:30 PM
Forum God


 
BboyTaktix's Avatar
 
Join Date: Oct 2009
Location: CANADA! Montreal (party city), Quebec
Posts: 3,229
well according to zoomer at ZZP the bottom end of a 2.4 works on most 2.2's or something like that. But in this case I think the guy/mechanic you dealt with didn't know what the hell he was doing. I would definitely take it back and tell them to fix that shiiiit

---------- Post added at 05:30 PM ---------- Previous post was at 05:29 PM ----------

and I'm PRETTTTY sure you need a retune to run a 2.4 engine unless you also swapped the ECU's....and even then....

BboyTaktix
- 2011 Plasma Blue pearl WRX STI sedan
- SOLD -S256 TURBO 2.2 -SS/TC body, SS/Tc shocks/struts, B&G springs, 17"mags, TRS FX-R retrofits (50W/6000k)
BboyTaktix is offline  
post #5 of 8 (permalink) Old 09-07-2011, 03:08 PM
Contributor
 
LT1R's Avatar
 
Join Date: Oct 2009
Location: sugar grove ohio
Posts: 429
im pretty sure you could get it to work if you either got a tune or a ecu ment for a 2.4 but other than that the screwed u over and id go have them fix it,and make sure u plug everything back in because then they will say thats the problem and ur still screwed
LT1R is offline  
post #6 of 8 (permalink) Old 09-08-2011, 04:19 PM
Cobalt Specialist
 
Nighthawk243's Avatar
 
Join Date: Mar 2010
Location: Pittsburgh, Pistolvania
Posts: 1,218
Garage
Most likely it is still running the tune for the LAP, so it isn't running correctly because of the extra .2l of displacement. Use the LE5 manifold and have Trifecta retune the thing to work properly (Of if you're going to take it back, insist on them getting a custom tune to correct it, as well as using the LE5 mani.)


GM Stage II | 2nd Gen Projectors | 5000K Low Beams | 3000K HID Fogs | LED Tails| SS/TC Seats
▲RIP 2007 G5: Totalled 1/26/10▲
Nighthawk243 is offline  
post #7 of 8 (permalink) Old 09-27-2011, 08:49 PM
hawaii icon
Staff Alumni
YourCobalt of the Month Winner
YourCobalt.com Premium Member


 
agita_san's Avatar
 
Join Date: Feb 2010
Location: Makakilo, Hawaii
Posts: 3,089
Garage
Moved...

Aspire to Inspire the Aspirations of the Inspirational
www.facebook.com/islandecotecs
agita_san is offline  
post #8 of 8 (permalink) Old 09-28-2011, 05:56 PM
Staff Alumni
YourCobalt.com Premium Member


 
scagnetti76's Avatar
 
Join Date: Feb 2009
Location: Helena Mt
Posts: 3,700
Garage
Quote:
Originally Posted by BboyTaktix View Post




and I'm PRETTTTY sure you need a retune to run a 2.4 engine unless you also swapped the ECU's....and even then....
this^
but then to use the 2.2 mani's on the better flowing head. no wonder it runs like ass.
scagnetti76 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome