Engine Light Came On... - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 09-21-2011, 04:04 PM Thread Starter
Newcomer
 
Join Date: Sep 2011
Posts: 4
Thumbs down Engine Light Came On...

Beginning to hate my car The engine light came on when I started it up outside a store. No signs of issues and it runs normal. Took it to Advance Auto and they found two codes, one of which was about emissions, the other was pending and they couldn't see it?? IDK I'm not a huge car person but I know the basics. Figured on here someone would know what they were talking about but my brain sucks and I totally forgot what they said was wrong with it. I know it was something with the fueling.. had the words Injector, Cap , and Vent? maybe not cap, not sure.. again I can't remember Anyone hear of this happening and know what I'm talking about? They said it was also a dealer part and they couldn't get it, if that helps at all. OH! and had something to do with having to pump gas slowly otherwise the gas comes out? IDK I haven't had issues with filling her with gas and I hadn't gotten gas for about 3-4 days so I don't think it was the cap and I'm always careful with that. IDK anyone understand stupid?


Edit: Oh and It's a 2006 Chevy Cobalt LS... if that helps.

Last edited by coelh102; 09-21-2011 at 04:05 PM. Reason: addon
coelh102 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 09-21-2011, 04:36 PM
Forum Regular
 
Join Date: Jan 2010
Location: Willis, MI
Posts: 188
Garage
2006 LS you say? where do you live? sounds like my old car, get a gas cap. try that, if that dont fix it than its the Evap canaster.

2006 Cobalt LS-traded in
used 2008 Cobalt SS/TCFOR SALEhttps://www.yourcobalt.com/forums/car...tml#post819842
EuroBalt is offline  
post #3 of 14 (permalink) Old 09-21-2011, 04:42 PM Thread Starter
Newcomer
 
Join Date: Sep 2011
Posts: 4
I'm in NY. I hate to buy parts and have them not work, I have like no money and just became unemployed so what money I do have, has to last. Do you think it's safe to drive for a few weeks?
coelh102 is offline  
 
post #4 of 14 (permalink) Old 09-21-2011, 05:01 PM
Forum Regular
 
Join Date: Jan 2010
Location: Willis, MI
Posts: 188
Garage
id say so. Evap is so hard to Diag. if they said it wasnt the gas cap as i reread the post. id say its evap canasters since they said slow fill, when you fill it up does it shut off on fast fill? if so then its what i think it is the vent solinoid gets clogged or fails causeing that

2006 Cobalt LS-traded in
used 2008 Cobalt SS/TCFOR SALEhttps://www.yourcobalt.com/forums/car...tml#post819842
EuroBalt is offline  
post #5 of 14 (permalink) Old 09-21-2011, 05:05 PM
Forum Regular
 
Join Date: Aug 2011
Posts: 177
Garage
your probably just running too lean on your gas. go to a pepboys our auto zone or something around you have them run a code (for free) and im guessing your just gunna have to get some fluid cant remember what its called but it unblocks the fuel thats gathered in your engine like a blood clot.. legit its the same concept as a blood clot but on your car and with gas. had the same problem like 3 times its cuz i redline way too much do you beat the poop out of your car?

---------- Post added at 08:05 PM ---------- Previous post was at 08:03 PM ----------

had to reread your post cuz im drunk. but im guessing the other code is what i said. idk never had an emissions code before :X

Photobucket
Full 2.5 inch magnaflow exhaust system, injen short ram air intake, cobalt ss front bumper, cobalt ss wing, tinted tail lights, limo tint back 3 windows, 10k 55w hid's (helicopter hunting). And ofcourse.. DOMO!!!
silverslowbalt is offline  
post #6 of 14 (permalink) Old 09-21-2011, 05:10 PM
Forum Regular
 
Join Date: Jan 2010
Location: Willis, MI
Posts: 188
Garage
Quote:
Originally Posted by silverslowbalt View Post
your probably just running too lean on your gas. go to a pepboys our auto zone or something around you have them run a code (for free) and im guessing your just gunna have to get some fluid cant remember what its called but it unblocks the fuel thats gathered in your engine like a blood clot.. legit its the same concept as a blood clot but on your car and with gas. had the same problem like 3 times its cuz i redline way too much do you beat the poop out of your car?

---------- Post added at 08:05 PM ---------- Previous post was at 08:03 PM ----------

had to reread your post cuz im drunk. but im guessing the other code is what i said. idk never had an emissions code before :X
LOL's at drunk posting, always the best

2006 Cobalt LS-traded in
used 2008 Cobalt SS/TCFOR SALEhttps://www.yourcobalt.com/forums/car...tml#post819842
EuroBalt is offline  
post #7 of 14 (permalink) Old 09-21-2011, 05:12 PM
Forum Regular
 
Join Date: Aug 2011
Posts: 177
Garage
lmao wasted wednesday gotta take advantage!

Photobucket
Full 2.5 inch magnaflow exhaust system, injen short ram air intake, cobalt ss front bumper, cobalt ss wing, tinted tail lights, limo tint back 3 windows, 10k 55w hid's (helicopter hunting). And ofcourse.. DOMO!!!
silverslowbalt is offline  
post #8 of 14 (permalink) Old 09-21-2011, 05:14 PM
Contributor
 
keegs's Avatar
 
Join Date: Apr 2010
Posts: 311
Quote:
Originally Posted by coelh102 View Post
Beginning to hate my car The engine light came on when I started it up outside a store. No signs of issues and it runs normal. Took it to Advance Auto and they found two codes, one of which was about emissions, the other was pending and they couldn't see it?? IDK I'm not a huge car person but I know the basics. Figured on here someone would know what they were talking about but my brain sucks and I totally forgot what they said was wrong with it. I know it was something with the fueling.. had the words Injector, Cap , and Vent? maybe not cap, not sure.. again I can't remember Anyone hear of this happening and know what I'm talking about? They said it was also a dealer part and they couldn't get it, if that helps at all. OH! and had something to do with having to pump gas slowly otherwise the gas comes out? IDK I haven't had issues with filling her with gas and I hadn't gotten gas for about 3-4 days so I don't think it was the cap and I'm always careful with that. IDK anyone understand stupid?


Edit: Oh and It's a 2006 Chevy Cobalt LS... if that helps.
The quality of the responses to your stated problem will likely correlate to how careful you are in describing it.

2010 Cobalt XFE
2006 Chevy Colorado 4x4
2005 Toyota Corolla
2013 Kubota M5640 SUD
keegs is offline  
post #9 of 14 (permalink) Old 09-21-2011, 05:16 PM
Forum Regular
 
Join Date: Aug 2011
Posts: 177
Garage
Quote:
Originally Posted by keegs View Post
The quality of the responses to your stated problem will likely correlate to how careful you are in describing it.
im way too hammered to understand anything you just said... english pleasE? jajajaja

Photobucket
Full 2.5 inch magnaflow exhaust system, injen short ram air intake, cobalt ss front bumper, cobalt ss wing, tinted tail lights, limo tint back 3 windows, 10k 55w hid's (helicopter hunting). And ofcourse.. DOMO!!!
silverslowbalt is offline  
post #10 of 14 (permalink) Old 09-21-2011, 05:22 PM Thread Starter
Newcomer
 
Join Date: Sep 2011
Posts: 4
the guy I talked to said something about when you fill it does it stop? and that the gas spills out. When I put gas in it, no it does not stop, it fills up. Yes I am heavy on the gas pedal and usually run it til it is almost out of gas (less than a 1/16th) and sometimes the light does come on. Simply because I travel an hour to and from anything around here and forget to check the gas and it's usually 30mins before another gas station. So maybe just injector fluid will clear it up?
coelh102 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome