Please Help - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-06-2012, 06:39 PM Thread Starter
Newcomer
 
Join Date: Mar 2012
Posts: 1
Please Help

We have a cobalt LS 2007. We finally took it in to have the power stearing recall fixed. About a week later check engine light comes on, is on for 2 days, goes off for 3, then come back on for a day then off. Finally it came back on again so i take it to auto zone and they pull the code and says is the camshaft position sencor. They get me the part i put it in and then the car starts doing a hard start, and i have to hit the gas to get it to start. So i go back, they pull the codes again, same thing, get me a new sencor and i put that in, Started up fine but then 30 mins later, same starting problem. So i took it to the dealer they took a free 30 min look ( witch was manly pulling codes) said PO341 and PO340 were coming up and they think the harness has a wear on it or its the camshaft actuator. We brought it home, check out the harness it seems fine, we see no holes or anything. I googled some stuff and it says it could throw those codes if theres dirt in the oil. Please help i am at a lose. I just want it to work again.

Last edited by mesobunny; 03-06-2012 at 07:08 PM.
mesobunny is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome