Power Lock Issues - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 22 (permalink) Old 06-20-2012, 09:20 AM Thread Starter
Contributor
 
jignaczak's Avatar
 
Join Date: Dec 2011
Location: S.W. Pennsylvania
Posts: 455
Garage
Power Lock Issues

I have a strange issue with my power locks...but first a little background

about 2 months ago, my lock switches on the doors quit working, not a big deal, the locks still worked good from both my OEM keyless entry and my remote start remote

about 2 weeks ago, we had a MAJOR storm, came up quick, and I forgot that my windows were down, the inside of the car was SOAKED, and my locks were randomly locking and unlocking after that...I removed the fuse, let it dry out for a couple days, and reconnected the fuse...everything seemed fine..until I noticed:

everytime I open any of the doors, the door locks all automatically unlock...it doesn't matter if they are already unlocked, or just the drivers door is unlocked, the actuators all move, my door lock switches in the car still do not work, but other than that and the strange door open, all unlock, everything seems to work the way it is supposed to, doors lock upon start, and unlock when put into park, keyfobs all work correctly, ect

has anyone else ever run into an issue like this before?

John
2008 Cobalt LT
SS springs and Stagg struts
Pioneer AVIC-X930BT GPS
Memphis 16-MCH600 "Baby Belle" hybrid amplifier
MB quart Premium 6.5" componant/premium tweeters front
MB quart Premium 5.25 componant/premium tweeters rear
Memphis PR-10" sub in factory sub box

miles and miles of dynamat extreme...
jignaczak is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 06-20-2012, 02:24 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Do both sides not work passenger and driver?

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 22 (permalink) Old 06-20-2012, 02:27 PM
Super Moderator
Staff Alumni
YourCobalt of the Month Winner


 
Blackbalts's Avatar
 
Join Date: Aug 2011
Location: Burnsville, Minnesota
Posts: 5,481
Garage
After I got my car detailed my locks did the same thing for about 30 minutes. Haven't had a problem since.
Blackbalts is offline  
 
post #4 of 22 (permalink) Old 06-21-2012, 11:39 AM Thread Starter
Contributor
 
jignaczak's Avatar
 
Join Date: Dec 2011
Location: S.W. Pennsylvania
Posts: 455
Garage
both side door switches don't work, but no matter what door I open, it actuates the locks

John
2008 Cobalt LT
SS springs and Stagg struts
Pioneer AVIC-X930BT GPS
Memphis 16-MCH600 "Baby Belle" hybrid amplifier
MB quart Premium 6.5" componant/premium tweeters front
MB quart Premium 5.25 componant/premium tweeters rear
Memphis PR-10" sub in factory sub box

miles and miles of dynamat extreme...
jignaczak is offline  
post #5 of 22 (permalink) Old 06-21-2012, 11:41 AM
Super Moderator
Staff Alumni
YourCobalt of the Month Winner


 
Blackbalts's Avatar
 
Join Date: Aug 2011
Location: Burnsville, Minnesota
Posts: 5,481
Garage
Thats strange. Do the other buttons work like windows and mirror?
Blackbalts is offline  
post #6 of 22 (permalink) Old 06-21-2012, 04:38 PM Thread Starter
Contributor
 
jignaczak's Avatar
 
Join Date: Dec 2011
Location: S.W. Pennsylvania
Posts: 455
Garage
Windows and mirrors work fine


Sent from my Autoguide iPhone app

John
2008 Cobalt LT
SS springs and Stagg struts
Pioneer AVIC-X930BT GPS
Memphis 16-MCH600 "Baby Belle" hybrid amplifier
MB quart Premium 6.5" componant/premium tweeters front
MB quart Premium 5.25 componant/premium tweeters rear
Memphis PR-10" sub in factory sub box

miles and miles of dynamat extreme...
jignaczak is offline  
post #7 of 22 (permalink) Old 06-21-2012, 04:49 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
That might be a BCM setting. Maybe it went to default after you pulled the fuse for a lenght of time. Might need a Tech 2 or maybe there is a procedure in the manual.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #8 of 22 (permalink) Old 06-21-2012, 06:02 PM
Chevy Customer Service
YourCobalt.com Premium MemberExpert
 
ChevyCustSvc's Avatar
 
Join Date: Nov 2010
Location: Detroit, Michigan USA
Posts: 794
For what it's worth, have you played with the different Lock Personalization settings in the DIC? For more information on that, check out page 3-51 in the owner's manual ("DELAY LOCK" is the first of several options).
Hope this is helpful in some way!
Sarah
GM Customer Service
ChevyCustSvc is offline  
post #9 of 22 (permalink) Old 06-24-2012, 09:57 AM Thread Starter
Contributor
 
jignaczak's Avatar
 
Join Date: Dec 2011
Location: S.W. Pennsylvania
Posts: 455
Garage
Sarah, thanks for that, but the DIC settings made no difference, oh well, just another annoying little thing about this car


Sent from my Autoguide iPhone app

John
2008 Cobalt LT
SS springs and Stagg struts
Pioneer AVIC-X930BT GPS
Memphis 16-MCH600 "Baby Belle" hybrid amplifier
MB quart Premium 6.5" componant/premium tweeters front
MB quart Premium 5.25 componant/premium tweeters rear
Memphis PR-10" sub in factory sub box

miles and miles of dynamat extreme...
jignaczak is offline  
post #10 of 22 (permalink) Old 06-25-2012, 01:55 PM
Chevy Customer Service
YourCobalt.com Premium MemberExpert
 
ChevyCustSvc's Avatar
 
Join Date: Nov 2010
Location: Detroit, Michigan USA
Posts: 794
Quote:
Originally Posted by jignaczak View Post
Sarah, thanks for that, but the DIC settings made no difference, oh well, just another annoying little thing about this car


Sent from my Autoguide iPhone app
That's a bummer! :( Let me know if you ever decide to get this looked into with your dealership.

Best,
Sarah
GM Customer Service
ChevyCustSvc is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome