Highbeams Not Working - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-27-2012, 06:28 PM Thread Starter
Newcomer
 
Join Date: May 2012
Posts: 2
Post Highbeams Not Working

So the other night my drivers side headlight went out, but i still had highbeams. I went to canadian tire and bought a new 9007 bulb and installed it. After installation my lows and daytime running lights work but i now have no highbeams at all, also the indicator light on the dash doesnt come on anymore. I have checked the fuses and they are fine but i cant figure out why i have no highs. This is on an '06 cobalt lt. Any ideas??
NLoek is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-27-2012, 08:36 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Well this is odd. Each headlight filament is fused seperately, so pretty much unrealistic to think it would be the fuses if both lights don't work. Did you jumper low and high fuses to make sure your bulb filaments work? Only common thing between the 2 highbeams is the highbeam relay. But the highbeam relay is turn on at the same time as the blue icon lamp in the intrument panel via a different route mind you but by the same logic. BCM turns highbeams on and off when it gets the signal from the headlight lever.

Mmmmm, does your flash to pass (Optical Horn) work?

---------- Post added at 11:36 PM ---------- Previous post was at 09:59 PM ----------

In case it wasn't clear. With car off, jumper from boost post to any of the four headlight fuses. Each fuse will light a different filament in the headlight. So have a friend stand in front and you can check if all filaments are good. You have to start somewhere. Maybe this picture will help.


Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 5 (permalink) Old 07-28-2012, 01:29 PM Thread Starter
Newcomer
 
Join Date: May 2012
Posts: 2
I'll give it a try.
NLoek is offline  
 
post #4 of 5 (permalink) Old 07-30-2012, 07:12 AM
Veteran
 
i944scania's Avatar
 
Join Date: Jul 2012
Location: New Hampshire
Posts: 563
Garage
check that youve got the right blub

07 LSJ turbo swap
-to4e 50 trim .63 a/r @ 19psi
-2.5" intercooler system with zzp bov
-2.5" exhaust
-turbonetics deltagate II w/voodoo boost controller
-3" intake
-siemens #60s
-aem uego wideband afr
-HP custom tune


i944scania is offline  
post #5 of 5 (permalink) Old 07-30-2012, 07:59 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Different bulb would be keyed differently and not fit the socket, plus he said he bought 9007.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome