Code P0100 - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-11-2012, 11:45 PM Thread Starter
Newcomer
 
Join Date: Aug 2012
Posts: 1
Code P0100

So.. I'm completely New to forums first of all. I have an 09 ss turbo, it has a trifecta tune with Hahn exhaust to an HKS muffler. That's all lol. I've had the typical code of too much pressure in the gas tank, super easy to fix, gone in 2 hours. But recently I've had the code of p0100. I changed the mass air flow sensor and also put in a New filter, cleared the code and its back on next time I start the car. I haven't noticed any differences with how it is running, but there was 2 times where I didn't build boost in second gear..shifted and no problems. So any suggestions would be a lot of help, thanks!
brobalt is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-12-2012, 03:20 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
P0100 is a MAF malfunction, but not necessarily caused by MAF. P0100 is set when sensor fails to see 11 regulated volts as it's reference for more than twenty seconds. Common causes are; bad battery connections, bad battery, idle speed too low, or ECM itself not putting out proper voltage.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome