09 Cobalt LS Automatic Hard Shift - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 08-24-2012, 10:23 AM Thread Starter
Newcomer
 
Join Date: Jun 2012
Posts: 12
09 Cobalt LS Automatic Hard Shift

Hi all,
I'm new to this forum and in in need of some help.
my 2009 cobalt (LS 4 door) started shifting hard from 1st gear to 2nd. this only happens when I'm at a stopped light and drive off and when it shifts from 1st to 2nd it shifts hard that the you can feel the pull.
any advise what could it be. I would really appreciate.
its my daily driver car and its automatic transmission. the car has 176xxx miles. i just hope my transmission its not going out.
Thanks
09cobaltls is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 08-24-2012, 10:38 AM
Super Moderator
Staff Alumni
YourCobalt of the Month Winner


 
Blackbalts's Avatar
 
Join Date: Aug 2011
Location: Burnsville, Minnesota
Posts: 5,481
Garage
When did you flush the tranny fluid and replace the filter?


05 Mitsubishi Evolution 8
05 Chevy Cobalt LS (RIP 7/13/2013)
99 Nissan Altima GXE (Daily)
99 Subaru Legacy (Daily)
07 Jeep Liberty Limited (No longer the tow truck for the balt )

If you have questions and I'm not on please PM, notifications go straight to my phone 24/7.

My Showoff
Join YC on FB
Syndicate of Tuners.com
Blackbalts is offline  
post #3 of 16 (permalink) Old 08-24-2012, 10:49 AM Thread Starter
Newcomer
 
Join Date: Jun 2012
Posts: 12
it has never been done to my knowledge.
the dealer says it has a sealed transmission therefore the transmission fluid is lifetime.
09cobaltls is offline  
 
post #4 of 16 (permalink) Old 08-24-2012, 10:55 AM
Super Moderator
Staff Alumni
YourCobalt of the Month Winner


 
Blackbalts's Avatar
 
Join Date: Aug 2011
Location: Burnsville, Minnesota
Posts: 5,481
Garage
Your dealer is a dumb a$$

---------- Post added at 12:55 PM ---------- Previous post was at 12:55 PM ----------

I'll bet you are a quart or two low


05 Mitsubishi Evolution 8
05 Chevy Cobalt LS (RIP 7/13/2013)
99 Nissan Altima GXE (Daily)
99 Subaru Legacy (Daily)
07 Jeep Liberty Limited (No longer the tow truck for the balt )

If you have questions and I'm not on please PM, notifications go straight to my phone 24/7.

My Showoff
Join YC on FB
Syndicate of Tuners.com
Blackbalts is offline  
post #5 of 16 (permalink) Old 08-24-2012, 11:00 AM Thread Starter
Newcomer
 
Join Date: Jun 2012
Posts: 12
can i just add the quart myself or will i have to take it to the dealer.
i know the fill hole has a cap. do i just remove it and try to put the fluid in there?
or are there any specials tools needed??
thanks
09cobaltls is offline  
post #6 of 16 (permalink) Old 08-24-2012, 11:03 AM
Super Moderator
Staff Alumni
YourCobalt of the Month Winner


 
Blackbalts's Avatar
 
Join Date: Aug 2011
Location: Burnsville, Minnesota
Posts: 5,481
Garage
Where do you think there is a fill cap for your tranny fluid? I've never seen an auto?


05 Mitsubishi Evolution 8
05 Chevy Cobalt LS (RIP 7/13/2013)
99 Nissan Altima GXE (Daily)
99 Subaru Legacy (Daily)
07 Jeep Liberty Limited (No longer the tow truck for the balt )

If you have questions and I'm not on please PM, notifications go straight to my phone 24/7.

My Showoff
Join YC on FB
Syndicate of Tuners.com
Blackbalts is offline  
post #7 of 16 (permalink) Old 08-24-2012, 11:06 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
That is a vent cap, hold on let me find the thread for checking your fluid. Pretty sure that's not your problem though.

https://www.yourcobalt.com/forums/tra...08-cobalt.html

Did you check the "TCM" fuse? Pull it out of the slot to check it if it's good, check tabs for corrosion, flip 180 and re-install. If this doesn't solve it check the "TCM" ground strap (G105) on the transmission case front of engine.


Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly

Last edited by Coby7; 08-24-2012 at 11:23 AM.
Coby7 is offline  
post #8 of 16 (permalink) Old 08-24-2012, 11:50 AM Thread Starter
Newcomer
 
Join Date: Jun 2012
Posts: 12
ok thanks ill do this today when i get home.ill check the TCM fuse. i hope this solves my problem
09cobaltls is offline  
post #9 of 16 (permalink) Old 08-24-2012, 12:04 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Any DTCs? No DTCs means it isn't engine related, like sensors and such.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly

Last edited by Coby7; 08-24-2012 at 12:08 PM.
Coby7 is offline  
post #10 of 16 (permalink) Old 08-24-2012, 12:07 PM Thread Starter
Newcomer
 
Join Date: Jun 2012
Posts: 12
nope the car has no codes no lights.
except the TPMS light because it has after market wheels
09cobaltls is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome