Cobalt Having a Hard Time Starting After Replacing the Radiator. - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-29-2012, 08:58 AM Thread Starter
Newcomer
 
Join Date: Aug 2012
Posts: 1
Cobalt Having a Hard Time Starting After Replacing the Radiator.

I just replaced my radiator after hitting an small animal. I replaced the fluids with regular dilauted antifreeze. The people at the local Advance auto said it was fine to do that since their house brand is able to be used in any vehicle regardless of color. Will not cause a chemical reaction. Since changing the radiator I have had one heck of a time starting my car after only driving for a short period of time. I leave the car for anywhere from 5-30 minutes and it's having a hard time turning over. It starts perfect cold.The oil is fine so I think I'm safe to say that the head gasket isn't crack or blown. I'm losing my mind over what can be causing this. Any help will be appreciated.

---------- Post added at 01:58 PM ---------- Previous post was at 01:46 PM ----------

Highest temp it ran was 219 degrees since replacing the radiator. Could this be an ECT sensor going bad.
CCoyner73 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome