Service Traction and EVAP? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 1Likes
  • 1 Post By Coby7
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-23-2012, 05:57 PM Thread Starter
Newcomer
 
Join Date: Dec 2012
Posts: 1
Service Traction and EVAP?

Hi, I just bought a 2007 Cobalt LT a few days ago (with the 2.2L Ecotec engine) and it had the engine light on since I bought it. It turns off occasionally, and it was checked and I was told it was an EVAP code, and something in the gas tank needs to be cleaned as it takes gas very slowly. However, since I got it the "service traction" messages shows up, and the traction control turns off. But once the car is turned off, the light goes out and stays out for a while and trac seems to function normally. Ive never had any issues with the trac in my previous car (2000 Grand Prix GT). Im not familiar at all with these cars and their engines, as its a very big change from my grand prix. If anyone knows anything about what this EVAP thing in my gas tank that needs to be cleaned or why my service trac comes on, it would be super appreciated.

**also forgot to add, right after the service traction comes on the car seems like its going to stall and is very jerky for like a minute. then even with the trac light on, it drives completely normal. the shaking reminds me of what happened when the o2 sensor went in my GP, but I was told nothing is wrong with this o2 sensor.

Last edited by soonincx; 12-23-2012 at 06:00 PM.
soonincx is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-23-2012, 06:21 PM
Staff Alumni
 
money_man's Avatar
 
Join Date: Mar 2012
Location: Halifax, N.S
Posts: 3,127
its probably a lazy speed sensor on one of your front wheels or a loose connector. Chev's are horrible for abs lights. The grand prix's (I owned a 1997 grand prix) used to have the abs sensor wires break and they had to be fixed.

2009 Ford Escape Limited - 3.0L, 6 speed auto, 4x4, 25/33 city/hwy imp mpg.
2017 F150 XLT-XTR - 5.0L, 4x4, 3.55's, E-locker, xtr chrome package, fx4 off-road package.
20/25 imp mpg
money_man is offline  
post #3 of 4 (permalink) Old 12-23-2012, 06:32 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
If it's been sprayed against rust and the filler neck vent wasn't shielded then you might need to clean the rust proofing guck from the vent. Sometimes just a high pressure spray clears it.

Definitely wheel bearing speed sensor for your other problem. Car probably goes into power management until code comes up, thus the shaking.
solarboy likes this.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
 
post #4 of 4 (permalink) Old 12-26-2012, 10:13 AM
Chevy Customer Service
YourCobalt.com Premium MemberExpert
 
ChevyCustSvc's Avatar
 
Join Date: Nov 2010
Location: Detroit, Michigan USA
Posts: 794
Welcome to the forum, soonincx!

If you should ever have questions about warranty or recall information, or wanted assistance in the process of working with a dealership, please get in touch! I can be reached either by private message on the forum or email (see my signature) and ask that you include the last 8 digits of your VIN with your inquiry.

Sarah, GM Customer Service

Have you checked into Chevrolet Owner Center? You can maintain service history, check on warranty or recall information, and more. Visit my.chevrolet.com!
ChevyCustSvc is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome