Ignition/Steering - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-27-2013, 05:44 PM Thread Starter
Newcomer
 
Join Date: Jan 2013
Posts: 3
Ignition/Steering

2008 cobalt lt, automatic

Ignition would not turn and brake very stiff..

attempted jiggle key and move wheel at same time, no effect. turned wheel fully right, no effect and wheel locked.

removed hatch under wheel and pressed white button. no effect.

Please Advise.

Thank you.
tapandrack is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-27-2013, 05:58 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Not sure I understand. If you can't depress brake pedal you won't be able to turn the key. Almost sounds like you have wrong key in ignition. White button is to release ignition barrel to release key not vice-versa. Check fuses for brake switch, because it releases ignition and shifter. Check ignition switch.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly

Last edited by Coby7; 01-27-2013 at 06:37 PM.
Coby7 is offline  
post #3 of 6 (permalink) Old 01-27-2013, 06:04 PM Thread Starter
Newcomer
 
Join Date: Jan 2013
Posts: 3
I see, white button was the wrong route.

The key is correct and i used the spare..

I'm in the manual looking for the breaks switch fuse and cant locate. where do i locate this? once located what do i do with it? take out and put back in?
tapandrack is offline  
 
post #4 of 6 (permalink) Old 01-27-2013, 06:37 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Verify that your high brake lamp comes on when you press brake pedal. Fuse 9 of BCM fuse block (10 amp). If it's burnt replace it if it's good re-insert it in place and go to next step.

It could also be fuse 8 ignition switch (2 amp).

Even "BCM2 fuse 40amp" in the underhood fuse block.

---------- Post added at 10:37 PM ---------- Previous post was at 10:35 PM ----------

Does your dome light come on?

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #5 of 6 (permalink) Old 01-28-2013, 12:13 PM
Chevy Customer Service
YourCobalt.com Premium MemberExpert
 
ChevyCustSvc's Avatar
 
Join Date: Nov 2010
Location: Detroit, Michigan USA
Posts: 794
tapandrack,
Any updates? Let me know if I can be of any assistance (primarily, I can answer recall/warranty questions or help you in working with a dealership).
Sarah, GM Customer Service

Have you checked into Chevrolet Owner Center? You can maintain service history, check on warranty or recall information, and more. Visit my.chevrolet.com!
ChevyCustSvc is offline  
post #6 of 6 (permalink) Old 01-28-2013, 04:02 PM Thread Starter
Newcomer
 
Join Date: Jan 2013
Posts: 3
Hi again!

Well this morning i took my moms car to work. Later i asked her to get my car towed to the mechanics. She got everything in place and decided to test the car and for some odd reason, key turned, engine on, wheel unlocked, break works.

The mechanics said it could be a battery dying and to replace it myself to save a significant amount of cash
tapandrack is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome