Check Engine Light HELP! - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-12-2013, 01:15 PM Thread Starter
Newcomer
 
Join Date: Mar 2013
Posts: 2
Question Check Engine Light HELP!

Hi everyone this is my first post on yourcobalt, but anyways I have a question. I have a 2008 Cobalt LT coupe.

I just got my primary air injection pump replaced, and my secondary air injection pump replaced because my check engine light came on and they had water in them. They replaced both of them and it still came on two starts later, so I did some investigating and ended up finding the fuse going to the air pump was blown. I replaced that fuse and a few starts later the light went out and has not been on again for like five days. Kind of weird they didn't replace that fuse when they replaced the air pumps, but anyways my check engine light seems to be working weird now. In my cobalt manual it says that the light should come on during every start, however mine does not come on when I do a cold start, so I shut it off. Then right after I start it again and the light comes on as it should with all the other lights and then disappears. That is how it is suppose to work I believe. Is this something I should be concerned with? I really am just wondering if there is a wiring problem, or bulb problem maybe. Or should I just be happy that it appears to be operating correctly when I start it when it is not a cold start.

Thanks for the help in advance!
dgoodale5 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-12-2013, 04:18 PM Thread Starter
Newcomer
 
Join Date: Mar 2013
Posts: 2
anyone at all?
dgoodale5 is offline  
post #3 of 4 (permalink) Old 03-12-2013, 04:40 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
They don't make money changing a fuse. As far as the light it only stays on until ECM is boothed sometimes it's quick some time it's a little longer. Turn your key to on without starting the car "CEL" should be on and stay as long as the engine is not running, if it flickers or turns off you know you have an intermittent bulb or connection.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
 
post #4 of 4 (permalink) Old 03-13-2013, 06:24 AM
Chevy Customer Service
YourCobalt.com Premium MemberExpert
 
ChevyCustSvc's Avatar
 
Join Date: Nov 2010
Location: Detroit, Michigan USA
Posts: 794
Welcome to the forum, dgoodale5!
I'm sorry that as a customer assistance representative I can't be more helpful in regards to troubleshooting - I see that you've gotten some great insight already from Coby. I can assist with dealership matters - were the pumps replaced at a GM dealership?
Sarah, GM Customer Service

Have you checked into Chevrolet Owner Center? You can maintain service history, check on warranty or recall information, and more. Visit my.chevrolet.com!
ChevyCustSvc is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome