COMPLETE Electrical Loss PLEASE HELP!! - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 03-12-2013, 05:06 PM Thread Starter
EEH
Newcomer
 
Join Date: Dec 2012
Posts: 2
COMPLETE Electrical Loss PLEASE HELP!!

Hey everyone,
I have a 2006 Chevy Cobalt and I have recently been having major electrical issues with the car. When it starts up it seems very hesitant and almost forced, and the other day I went to turn the key in the car and nothing was lit up no indicator lights or anything. After messing around for about 20 minutes i discovered there was a big red 50 amp fuse in the trunk of the car by the battery, I pulled it out (there was a spark) and pushed it back in nice and tight (another spark) and when I placed my key back in the ignition everything lit up and my car started. But when it did the engine began to make a knocking noise and vibrated quite a bit, worried that one of the valves was misfiring i quickly turned the key and killed the engine, waited about 2 minutes and when I started the car at that point the engine was fine and it was if nothing had happened....

I dont know what is going on with the car but i feel like it really has to do with that rear battery and 50amp fuse. If anyone has any insight at all it would be greatly appreciated!


Thanks for taking the time to read this.
EEH is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 03-12-2013, 06:31 PM
Staff Alumni
 
money_man's Avatar
 
Join Date: Mar 2012
Location: Halifax, N.S
Posts: 3,127
I would just do a quick check to make sure all other fuses are good and tight. It may have just been a random occurrence. Has it done it again?

2009 Ford Escape Limited - 3.0L, 6 speed auto, 4x4, 25/33 city/hwy imp mpg.
2017 F150 XLT-XTR - 5.0L, 4x4, 3.55's, E-locker, xtr chrome package, fx4 off-road package.
20/25 imp mpg
money_man is offline  
post #3 of 8 (permalink) Old 03-12-2013, 06:48 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
That Big Red fuse is the "BCM" fuse. If you had no power chances are it was your battery connection that was bad, or your boost post is loose.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
 
post #4 of 8 (permalink) Old 03-13-2013, 04:46 AM
Contributor
 
Join Date: Nov 2008
Location: Clovis, NM.
Posts: 360
Garage
^^^ ditto, check that the terminals are tight on the battery !

07 G5 GT

Cherry's Tree


Randy
Now serving Boost
272whp 276wtq @10psi
Cherry GT is offline  
post #5 of 8 (permalink) Old 03-13-2013, 05:19 AM
Staff Alumni
 
money_man's Avatar
 
Join Date: Mar 2012
Location: Halifax, N.S
Posts: 3,127
I always forget to say that because to me it's common sense to check battery terminals, although I always forget to mention the post under the hood

2009 Ford Escape Limited - 3.0L, 6 speed auto, 4x4, 25/33 city/hwy imp mpg.
2017 F150 XLT-XTR - 5.0L, 4x4, 3.55's, E-locker, xtr chrome package, fx4 off-road package.
20/25 imp mpg
money_man is offline  
post #6 of 8 (permalink) Old 03-13-2013, 05:58 AM Thread Starter
EEH
Newcomer
 
Join Date: Dec 2012
Posts: 2
This is the second time it has occurred, and both times pull that fuse and pushing it back in fixed the issue, but immediately afterwards the engine had that rumbling vibrating issue, is that part of it? and what exactly is a boost post?
EEH is offline  
post #7 of 8 (permalink) Old 03-13-2013, 09:20 AM
Staff Alumni
 
money_man's Avatar
 
Join Date: Mar 2012
Location: Halifax, N.S
Posts: 3,127
under the hood on the right side you'll see a red plastic cap on your fuse box, pull off the cap and make sure the post under it isn't loose, if it is then it needs to be tightened

2009 Ford Escape Limited - 3.0L, 6 speed auto, 4x4, 25/33 city/hwy imp mpg.
2017 F150 XLT-XTR - 5.0L, 4x4, 3.55's, E-locker, xtr chrome package, fx4 off-road package.
20/25 imp mpg
money_man is offline  
post #8 of 8 (permalink) Old 03-13-2013, 12:11 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
When it happens does your radio still work?

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome