Bad Amp? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 04-16-2013, 02:25 PM Thread Starter
Initiate
 
Join Date: Mar 2013
Location: Texas
Posts: 48
Bad Amp?

So, I have a kenwood 12" woofer set up in the back powered by a kenwood class D 1000W mono amp. For a long while, it worked. It wasn't pretty, it was the first thing I'd ever done to mod any car, but it worked. A friend of mine who installs car electronics for a living offered to clean up my wiring for me. he did that, and now you can barely tell that there are wire, however shortly after, the amp stopped working. I have it unhooked from a fuse right now, but when it is hooked up, the amp comes on (power signal light lights up at least) and stays on for a little while, but when I start playing music, as the woofer draws poser to kick, the power signal light starts to flicker, and soon dies and the woofer stops kcking. I havent found the time to actually try and figure out what is the prolem, but I figured I would post here to see if anyone has any ideas.
P.S. stock head unit, signal is tapped into Alpine 6x9's in the back.
Corran54 is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 04-16-2013, 03:01 PM
Staff Alumni
 
Rriggs92's Avatar
 
Join Date: Mar 2012
Location: Fort Wayne, Indiana
Posts: 1,345
Check the ground first


Sent from AutoGuide.com App
Rriggs92 is offline  
post #3 of 19 (permalink) Old 04-16-2013, 03:27 PM Thread Starter
Initiate
 
Join Date: Mar 2013
Location: Texas
Posts: 48
Ground is good. It's screwed into the metal sidewalling.
Corran54 is offline  
 
post #4 of 19 (permalink) Old 04-16-2013, 05:52 PM
Staff Alumni
 
Rriggs92's Avatar
 
Join Date: Mar 2012
Location: Fort Wayne, Indiana
Posts: 1,345
Did you check it? Or are you telling me where it's grounded?

Check all the wires into the amp as well as fuses in it if yours has any


Sent from AutoGuide.com App
Rriggs92 is offline  
post #5 of 19 (permalink) Old 04-16-2013, 05:59 PM
Staff Alumni


 
Jmesl8er's Avatar
 
Join Date: May 2011
Location: NKY
Posts: 1,316
Whats your gain on?
Jmesl8er is offline  
post #6 of 19 (permalink) Old 04-16-2013, 06:00 PM
Staff Alumni
 
Rriggs92's Avatar
 
Join Date: Mar 2012
Location: Fort Wayne, Indiana
Posts: 1,345
Quote:
Originally Posted by Jmesl8er View Post
Whats your gain on?
Yea if its up to high it will probably cut out and not work as well


Sent from AutoGuide.com App
Rriggs92 is offline  
post #7 of 19 (permalink) Old 04-16-2013, 06:10 PM
Staff Alumni


 
Jmesl8er's Avatar
 
Join Date: May 2011
Location: NKY
Posts: 1,316
Also the way you have it hooked up to the head unit isn't very good. Signal sucks. Go out and buy a 100 dollar head unit at Walmart
Jmesl8er is offline  
post #8 of 19 (permalink) Old 04-16-2013, 10:28 PM
Staff Alumni
 
Rriggs92's Avatar
 
Join Date: Mar 2012
Location: Fort Wayne, Indiana
Posts: 1,345
Quote:
Originally Posted by Jmesl8er View Post
Also the way you have it hooked up to the head unit isn't very good. Signal sucks. Go out and buy a 100 dollar head unit at Walmart
Whoa now. While that hu would be better its still not worth wasting a Hundo

He is right about the signal though. Get a nice stereo


Sent from AutoGuide.com App
Rriggs92 is offline  
post #9 of 19 (permalink) Old 04-17-2013, 07:50 AM Thread Starter
Initiate
 
Join Date: Mar 2013
Location: Texas
Posts: 48
It's grounded well.
I'll check my gain after school and let you know after school.
all the wires and fuses are good.
Signal might suck, but it works just fine when the amp is on.
Corran54 is offline  
post #10 of 19 (permalink) Old 04-17-2013, 09:23 AM
Staff Alumni


 
Jmesl8er's Avatar
 
Join Date: May 2011
Location: NKY
Posts: 1,316
Quote:
Originally Posted by Corran54 View Post
It's grounded well.
I'll check my gain after school and let you know after school.
all the wires and fuses are good.
Signal might suck, but it works just fine when the amp is on.
Hook it up to a head unit and you'll see a big difference.
Jmesl8er is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome