Engine Light Came on then Went Off About 10 Minutes of Driving - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-13-2013, 04:49 PM Thread Starter
Forum Regular
 
Denther's Avatar
 
Join Date: Jun 2012
Posts: 60
Engine Light Came on then Went Off About 10 Minutes of Driving

Well I was drag racing a friend at a stoplight and just punched it. Just messing around after school.

Anyway I'm not sure exactly when but as I was accelerating I noticed my check engine light was on this. I don't think this had been on when I started the car a few minutes previous but it is possible. I know it wasn't on in the morning. Anyway the light came on. I finished driving home and checked my gas cap and it still was on. Car acted completely fine, no weird sounds or bogging down, high revs, anything. Completely normal.

About an hour later I left home and the light was still on, then about 4 minutes of driving later it was off and has stayed off since (1 other short trip since).

Should I be worried or was it just a fluke?

Thanks.

- Denther -

2005 Cobalt LS Sedan
Slow and Stock
Denther is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-13-2013, 04:55 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Never a fluke. But conditions may have caused it to come on. If you are concerned it will be in history of your ECM. If the problem doesn't come back after so many startups, the code will be erased from history.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 6 (permalink) Old 05-13-2013, 05:18 PM Thread Starter
Forum Regular
 
Denther's Avatar
 
Join Date: Jun 2012
Posts: 60
I'm guessing I'd just stop at like Firestone and get it checked there?

- Denther -

2005 Cobalt LS Sedan
Slow and Stock
Denther is offline  
 
post #4 of 6 (permalink) Old 05-13-2013, 07:03 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Sometimes just a drop of water in the fuel line will do this. Once water goes through everything goes back to normal.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #5 of 6 (permalink) Old 05-13-2013, 07:17 PM Thread Starter
Forum Regular
 
Denther's Avatar
 
Join Date: Jun 2012
Posts: 60
Alright thanks for the speedy help. If it does it again or starts acting weird I'll get it checked.

- Denther -

2005 Cobalt LS Sedan
Slow and Stock
Denther is offline  
post #6 of 6 (permalink) Old 05-13-2013, 09:58 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
it was probably an o2 sensor running rich when you floored it and it just went away once you drove normally

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome