Lsj Runs Peg Rich on Wideband - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 05-16-2013, 05:53 PM Thread Starter
Newcomer
 
Join Date: Mar 2012
Location: V-town,Tx
Posts: 8
Exclamation Lsj Runs Peg Rich on Wideband

Hi im Jose, im new to this site and wanted to see if anyone found a solution to this problem. I have a 2007 cobalt ss s/c, just install a 2.1L gen3 gridle block, neutral balance shafts, 4340 rods, je pistons 9:5:1 ratio, port and polished head with stage2 cams, #78 valve springs and retainers, ati balancer, Zzp3" intake, zzp long tubes, hypersingle clutch stage3, 3" exhaust, tvs 1320 supercharger on 2.8 pulley on new tune.

This is my problem, at idle it jumps from 500-1500 rpms. At random times it falls to 10 afr, thenwants to stall out. I replaced map, and ignition coils, spark plugs, injector harness, also replaced o2 sensors. I checked for short to ground on maf and resistance. Cant seem to figure it out, if any one had a problem like this please help!
ironman07sc is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 05-16-2013, 07:57 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
is your tps whacking out? how's it drive under wot and cruising? who tuned you?

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #3 of 15 (permalink) Old 05-17-2013, 04:31 PM Thread Starter
Newcomer
 
Join Date: Mar 2012
Location: V-town,Tx
Posts: 8
I have the ls4 tb and had a spare, swapped it out and still acts up. I ordered stock lsj tb cuz im tired of a touchy throttle. I got tuned by laser (kendall) from houston tx, he had tuned my car and it was running mean. It was acting up before he tuned it and it was for rear o2 sensor cuz it was deleted, he turned off codes but now check engine light blinks for a while then turns off after car stops running rich, im thinking the computer went to crap.
ironman07sc is offline  
 
post #4 of 15 (permalink) Old 05-17-2013, 05:12 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Have you checked your spark plugs? What cylinder is misfiring?

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #5 of 15 (permalink) Old 05-17-2013, 08:24 PM Thread Starter
Newcomer
 
Join Date: Mar 2012
Location: V-town,Tx
Posts: 8
Well a wot its fine, no misfire, checked plugs and still white. I got dem gapped at .027
ironman07sc is offline  
post #6 of 15 (permalink) Old 05-17-2013, 08:34 PM
Levee
YourCobalt of the Month Winner
YourCobalt.com Premium Member
Admin


 
Leveecius's Avatar
 
Join Date: Aug 2009
Location: Battle Creek, MI
Posts: 3,210
Garage
Send a message via Yahoo to Leveecius
Have you data logged it?

'09 SS/TC - Stolen
Mods - Injen CAI, CIA MAF Relocate CP's, Dejon FMIC,
Custom 3" DP, 3" Exhaust, GT3076R, Pioneer AVH-4100DVD, Hurst STS, ZZP triple pod, Autometer Cobalt boost/DPIC/WB gauges, Nitto NT05 245/40/18's, H&R Springs, 80:20 Meth Spray
Future - KSport Kontrol Pro Coilovers, 10% Tint, FMIC spray
538whp/501wtq @38 psi on meth and 93 oct on stock ish motor


06 EVO IX MR/SE - Sold
Mods - *Updated 10/6/13* AEM TRUboost EBC, 4in custom TBE, SD dual 93/e85 tune, ETS 4in Race Core FMIC, Dual Aeromotive 400lph Fuel Pumps, T4 Tubular Manifold w/ dual WG's, FP Super99HTZ DBB Turbo, GSC 274 mivec cams, ARP headstuds/rod studs, FIC 2150cc Injectors, Aeromotive FPR, Aeromotive Fuel Rail, catch can, Mini Battery Kit, Slim Coolant Fan, Kiggly Racing high pressure valve Springs/Titanium Retainers, Supertech Stainless Steel Valves, Dual VTA Tial 44mm WG's, 4g64 Stroker Manley Pistons, 155mm 2.4 LR Manley Turbo Plus I Beam Rods with ARP 625 Studs, 100mm forged non-billet Manley Crankshaft, Full H/E PNP with Port Matching, Kiggly Racing Girdle, Dual Tial 50mm BOV's, Excedy Triple Disc Carbon HD Clutch, AEM EMS

'95 Ram 2500 Diesel
Mods - 5in TBE, Boost Elbow set to 28psi, Adjusted fuel pump, Open Turbo.

Future Mods- Super Street Clutch (rated @1400ftlbs tq), 67mm turbo, 160lb valve springs, added timing, tubular exhaust manifold, larger injectors, possible 6 spd swap.


Master ASE Certified Gasoline/Diesel Technician since 2004

Speed Junkies Social Group

Yourcobalt Official Facebook Page!

Syndicate of Tuners Official Page! Up and going again as of 1/11/13

Click here to PM me if you have questions or issues!
Leveecius is offline  
post #7 of 15 (permalink) Old 05-18-2013, 05:12 PM Thread Starter
Newcomer
 
Join Date: Mar 2012
Location: V-town,Tx
Posts: 8
No I havent data logged it with hpt, all I have to go by is my intercepter and obd2 scanner with datalog freeze frame. I just checked today and my throttle percent is not working, just cleaned it and reinstalled rear o2 sensor, still runs like crap tb percent is not working still
ironman07sc is offline  
post #8 of 15 (permalink) Old 05-18-2013, 05:51 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
that might be your issue. tps went out maybe. new lsj throttle body is like 50-60 on amazon

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #9 of 15 (permalink) Old 05-18-2013, 07:37 PM Thread Starter
Newcomer
 
Join Date: Mar 2012
Location: V-town,Tx
Posts: 8
Yea it might be, but it was acting up before, and I had swapped tb lk two weeks ago and still was acting up. I got an lsj tb but Im not tuned fof it. I tri ed d to put it on and my balt was acting a little better but still wanted to stall.... I wish I had a tuner closer to victoria tx
ironman07sc is offline  
post #10 of 15 (permalink) Old 05-18-2013, 09:16 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
are you getting any codes?

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome