Have Gone Through 4 Alternators in 6 Months - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 05-29-2013, 05:20 PM Thread Starter
Newcomer
 
Join Date: May 2013
Posts: 3
Have Gone Through 4 Alternators in 6 Months

I have a 2005 4 cylinder automatic transmission Cobalt. I have had the alternator replaced 4 times since November at the dealership. There must be something else going on to cause this. I've had the latest one 1 week & today the check engine light came on. Any advice would be welcome.
sevenbundy is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 05-29-2013, 05:40 PM
Super Moderator


 
Bronxknight28's Avatar
 
Join Date: Oct 2011
Location: Bronx, N.Y.
Posts: 2,635
Garage
Start by getting the code read at autozone (free) and let us know what the code is. That's a start

WA636R - Switchblade Silver Mt 09 Sedan LT 2.2L LAP......Auto!

MODS:Fe5 TC Shock + Struts\Moog Endlinks\YYZ V1 Springs\SC Gunmetal Wheels. Badmab Shorty Header\GMPP Performance Exhaust\ZZP 2.5 Catted DP\K&N Drop-in filter\High Flow Intake Tube. Gen4 Headlights\6K Low Beam HID\LED 3rd Brake Light\LED Turn Signals,Plate,Trunk, Dome, Reverse, Side-marker\ Debadge "LT" & GM fender badges\Shorty Antenna

Join YC.com on Facebook! Like YC.com on facebook too!
Bronxknight28 is offline  
post #3 of 13 (permalink) Old 05-29-2013, 06:06 PM
Super Moderator
Staff Alumni
YourCobalt of the Month Winner


 
Blackbalts's Avatar
 
Join Date: Aug 2011
Location: Burnsville, Minnesota
Posts: 5,481
Garage
What do they say is the issue for why it needs to be replaced?

Sent from AutoGuide.com Free App


05 Mitsubishi Evolution 8
05 Chevy Cobalt LS (RIP 7/13/2013)
99 Nissan Altima GXE (Daily)
99 Subaru Legacy (Daily)
07 Jeep Liberty Limited (No longer the tow truck for the balt )

If you have questions and I'm not on please PM, notifications go straight to my phone 24/7.

My Showoff
Join YC on FB
Syndicate of Tuners.com
Blackbalts is offline  
 
post #4 of 13 (permalink) Old 05-31-2013, 11:24 PM
Forum Regular


 
cobaltune's Avatar
 
Join Date: Nov 2012
Location: Houston Texas
Posts: 153
Garage
sounds like a wiring problem,...id check for a grounding issue

0-60....tooloonggg......Someone Wanna tune me =)
cobaltune is offline  
post #5 of 13 (permalink) Old 06-01-2013, 08:54 AM
I cut stuff
YourCobalt of the Month Winner
YourCobalt.com Premium Member


 
blazerlow's Avatar
 
Join Date: Aug 2009
Location: MN
Posts: 6,238
Garage
check engine light shouldn't have anything to do with your alternator.
blazerlow is offline  
post #6 of 13 (permalink) Old 06-01-2013, 08:56 AM
Forum Regular


 
cobaltune's Avatar
 
Join Date: Nov 2012
Location: Houston Texas
Posts: 153
Garage
...

^^^ this

0-60....tooloonggg......Someone Wanna tune me =)
cobaltune is offline  
post #7 of 13 (permalink) Old 06-02-2013, 05:23 PM Thread Starter
Newcomer
 
Join Date: May 2013
Posts: 3
Quote:
Originally Posted by Blackbalts View Post
What do they say is the issue for why it needs to be replaced?

Sent from AutoGuide.com Free App
They say they were defective alternators. I'm no mechanic but the odds of that happening 4 times is pretty slim. The last one lasted 3 months.
sevenbundy is offline  
post #8 of 13 (permalink) Old 06-02-2013, 07:09 PM
Staff Alumni


 
Jmesl8er's Avatar
 
Join Date: May 2011
Location: NKY
Posts: 1,316
What brand are they using? I went through 3 duralast's in 6 months.
Jmesl8er is offline  
post #9 of 13 (permalink) Old 06-03-2013, 10:56 AM
Forum Regular


 
cobaltune's Avatar
 
Join Date: Nov 2012
Location: Houston Texas
Posts: 153
Garage
Quote:
Originally Posted by sevenbundy View Post
They say they were defective alternators. I'm no mechanic but the odds of that happening 4 times is pretty slim. The last one lasted 3 months.
Id bet money that its just a bad conection ,....i doubt they were all defective ...it probably just got shorted ......

0-60....tooloonggg......Someone Wanna tune me =)
cobaltune is offline  
post #10 of 13 (permalink) Old 06-03-2013, 12:23 PM
Forum Regular
 
Join Date: Nov 2010
Posts: 220
Cobalt are notorious for wiring problems. Took me almost two weeks to figure out why my parking light fuse kept blowing.
Cobalt1986 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome