Fuel Pump??? Electrical Issue?? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-29-2013, 07:38 PM Thread Starter
Newcomer
 
Join Date: May 2013
Posts: 1
Exclamation Fuel Pump??? Electrical Issue??

I have a 07 Chevy Cobat Lt coupe. 108k. Drove The car saturday night with no issues, let it sit all day sunday, went to start it up monday evening and it wouldnt start. It seemed as if the battery was dead so i had it jumped it started up fine, we also checked all the fuse's to make sure nothing was pulling alot of Juice while the car was off and we found nothing, also checked the battery and alternator and there fine, i drove it a lil bit and noticed the motor bogged down alot when i would apply the brakes, didnt think much of it at the time...i figured the AC (we're having issues with it as well) brought it back home let it set all day tuesday, went to start it up this evening (wednesday) and its doing the same thing. It is possible that i did get some bad gas which is making me think it might be the fuel pump but as i said i did have to have a jump to get the car to start. so any help solving the issue would be greatly appreciated. Thank You.
1991Loriann is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-30-2013, 04:34 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
I would start by cleaning the connectors at the battery and especially the ones @ the boost post. Remove boost post and clean wire tabs or lugs.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 5 (permalink) Old 05-31-2013, 02:48 PM
Forum Regular


 
cobaltune's Avatar
 
Join Date: Nov 2012
Location: Houston Texas
Posts: 153
Garage
Quote:
Originally Posted by Coby7 View Post
I would start by cleaning the connectors at the battery and especially the ones @ the boost post. Remove boost post and clean wire tabs or lugs.
^^ this and make sure to check your fuel filter alot of people neglect that

0-60....tooloonggg......Someone Wanna tune me =)
cobaltune is offline  
 
post #4 of 5 (permalink) Old 05-31-2013, 03:44 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Fuel filter won't stop starter from turning....

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #5 of 5 (permalink) Old 06-01-2013, 12:27 AM
Forum Regular


 
cobaltune's Avatar
 
Join Date: Nov 2012
Location: Houston Texas
Posts: 153
Garage
Quote:
Originally Posted by Coby7 View Post
Fuel filter won't stop starter from turning....
it will cause bogging ....i never read about the starter issue ...read what sounds like a lose wire or bad connection...

0-60....tooloonggg......Someone Wanna tune me =)
cobaltune is offline  
Sponsored Links
Advertisement
 
Closed Thread

Tags
alternator , battery , electrical , fuel pump

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome