2006 - Secondary Air Injection System Problems - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-06-2013, 04:29 PM Thread Starter
Newcomer
 
Join Date: Jun 2013
Posts: 3
2006 - Secondary Air Injection System Problems

My Cobalt keeps coming up with the P0411 code. It also had another code for the air injection sensor.

I replaced the air pump, sensor, and the fuse. It is still showing up with a P0411 code (sensor code has since disappeared). I took it to the dealer to run a diagnostic, and they keep saying it's the air pump, but I've already replaced that.

From time to time, my car seems to shut off if I'm going very slow, hitting the breaks (around 5 mph), and the conditions are just right. Could this have anything to do with it?

I'm sorry, I'm definitely not a mechanic, and I'm just trying to do research before I make my next move. This is already proving to be a costly situation.

---------- Post added at 05:29 PM ---------- Previous post was at 05:26 PM ----------

Also, it might be nice information to know that EVERY TIME I open my car door, the car alarm goes off. If there is a fix for that, PLEASE tell me. The stares are what gets me every time. Ha ha!
avybastyr is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-06-2013, 04:48 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Pump was probably good. Your P0411 is the secondary Air check valve. It is probably sticking.



Don't your remotes FOBs work?

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly

Last edited by Coby7; 06-06-2013 at 04:55 PM.
Coby7 is offline  
post #3 of 7 (permalink) Old 06-06-2013, 06:11 PM Thread Starter
Newcomer
 
Join Date: Jun 2013
Posts: 3
FOBs

No, they do not. I assume you're referring to both keyless entry as well as the interior lock/unlock buttons.
Thank you for your help! I will try that on Saturday.
avybastyr is offline  
 
post #4 of 7 (permalink) Old 06-06-2013, 07:19 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
If you repair your remotes, then when you press unlock it will disarm the alarm.

https://www.yourcobalt.com/forums/ele...r-key-fob.html

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #5 of 7 (permalink) Old 06-07-2013, 09:56 AM
Initiate
 
Join Date: Jan 2013
Posts: 39
How is the alarm set if the fob and door locks don't work? The alarm should only set when locked with the fob, not the door lock button.
fury is offline  
post #6 of 7 (permalink) Old 06-07-2013, 11:26 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
But it won't disarm without the FOB, I don't think!

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #7 of 7 (permalink) Old 06-07-2013, 06:08 PM Thread Starter
Newcomer
 
Join Date: Jun 2013
Posts: 3
Alarm

I'm not sure why it keeps doing that. The doors will be unlocked, but every time the door is opened it goes off. It just started doing that one day.

Since I've owned the car, the remote FOB have never worked, and when this problem began the interior electronic lock/unlock keys no longer work. Sometimes (rarely) I will be driving and the car will lock and unlock itself.

I've always had a mess of car problems.

Also, if cleaning out the pipes does not work, what will my next steps be? Again, I apologize for the naivety, but I'm trying to learn. The mechanic I usually take it to said that Chevys are really bad about check engine lights. He recommended getting the computer reset, but that doesn't seem right to me?
avybastyr is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome