BAH P0327 & P0326 Any Had Experience with It? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-21-2013, 06:45 PM Thread Starter
Newcomer
 
Join Date: Jun 2013
Posts: 3
BAH P0327 & P0326 Any Had Experience with It?

Codes are P0327 and P0326 Indication from the knock sensor...

2010 Cobalt 2.2 4 cyl Echotec 4 door sedan




Off the bat i replaced the knock sensor because it was a 20$ part so i was hoping for the easy fix but no luck... The engine doesn't seem to lack in power (althowe it may be) and the engine runs smooth... Seems to me like a bad PCM?


Anyone had experience with this issue.. also is replacing a PCM a novice operation or should i get some helped with someone with some experience?

Last edited by kingchipo; 06-21-2013 at 06:47 PM.
kingchipo is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-21-2013, 07:13 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
If you have both codes chances are your knock sensor has lost it's connection or it is bad. Check connection first, if connections are good chances are your knock sensor has bit the dust.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 6 (permalink) Old 06-21-2013, 07:19 PM Thread Starter
Newcomer
 
Join Date: Jun 2013
Posts: 3
Quote:
Originally Posted by Coby7 View Post
If you have both codes chances are your knock sensor has lost it's connection or it is bad. Check connection first, if connections are good chances are your knock sensor has bit the dust.

Yeah i replaced the knock sensor off the bat. Only 26$ bucks so w/e


Light came back on. as soon as i get my hands on a multimeter im gona check the connection and recheck my torque specifications...

what are the chances you think it could be the PCM?

Last edited by kingchipo; 06-21-2013 at 07:21 PM.
kingchipo is offline  
 
post #4 of 6 (permalink) Old 06-22-2013, 03:30 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Slim.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #5 of 6 (permalink) Old 06-23-2013, 06:10 PM Thread Starter
Newcomer
 
Join Date: Jun 2013
Posts: 3
Well tell me if this is a wierd solution.


After consulting with my father, who is a long time mechanic, he said that i should try and take off the hose connecting the valve cover to the intake. After removing the hose and plugging the intake whole. The engine light hasn't returned.. I was using valvoline full synthetic.. Very odd ill try to change the oil type and see if the engine light returns

Last edited by Coby7; 06-23-2013 at 06:37 PM.
kingchipo is offline  
post #6 of 6 (permalink) Old 06-23-2013, 06:42 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
I fail to see the rapport here! Maybe your father can enlighten us. By removing the hose you automatically change timing because you just plugged a vacuum inlet. Try Premium gasoline for a tank with everything back to normal. Bypassing a problem is not fixing it but might be a clue.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome