Electrical PROBLEMS! - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-07-2013, 09:52 AM Thread Starter
Newcomer
 
Join Date: Apr 2009
Posts: 2
Electrical PROBLEMS!

Well, I own a 2008 Cobalt sport. I have had the Valve timing solenoid thing go out already, replaced it, now the code is being thrown again, for the same one. To add to that, I have this intermittent issue with my coolant temperature sensor, it randomly does not read, when it is not reading, my AC does not work (does not blow cold air), when it does read, AC works fine..but wait, there's more! One day my ESC light randomly came on, as well as the light for the ABS system, guess both of those dont work. To add to the issues I have, my gas tank started leaking just yesterday (evidently a recall item I will have fixed soon) and two weeks ago, water started getting into the car on the drivers side, my carpet smells like mildew and it has been raining non stop here in SC. My 81 datsun didnt even have this many issues, and it was completely rusted out! Anyone else have the same problems? I have looked, people have similiar issues, but not at the same time...etc. Thanks.
maroonsport is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-07-2013, 10:29 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Bring it in if you still have warranty!!!

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 5 (permalink) Old 07-08-2013, 09:27 AM Thread Starter
Newcomer
 
Join Date: Apr 2009
Posts: 2
Well past warranty unfortunately.
maroonsport is offline  
 
post #4 of 5 (permalink) Old 07-08-2013, 11:38 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Well, then you are going to have to tackle these one at a time. Looks like a bunch of bad contacts. Clean your grounds, remove and reinsert all fuses. Then see how many of these problems are left.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #5 of 5 (permalink) Old 07-11-2013, 01:26 PM
Initiate
 
Join Date: Jun 2008
Location: Utah
Posts: 50
Sorry to hear about your car. I too have a 2008 sport coupe. Bought new in March '08. Only known electical problem was engine shutting off while driving. Very scary. Dealer couldn't replicate problem so replaced BCM and hoped for the best. Five month's later, happened again. Dealer added redundant ground wires and that seemed to do the trick. That was November 2011 and no electrical problems since. Just turned 22k miles a few weeks ago. So very low miles on this car.

Do you have a sunroof? Maybe sunroof drains are clogged causing water on floor. Just a guess. Happened on my Saturn a lot.

Good luck. I hope you don't encounter more problems with your car.

'08 LT Sport Coupe
eggalegga is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome