P0010 and P0011 - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-11-2013, 04:09 PM Thread Starter
Staff Alumni


 
kmac's Avatar
 
Join Date: Jun 2012
Location: Coxsackie, NY
Posts: 297
P0010 and P0011

So my CEL has been on for a bit now and I finally went to advance to check the code. Those are the two codes that popped up. I looked them up and found they are cam position sensor related. Would be that easy as to just replace the sensor? I also read somewhere that it could be oil level related and I was due for an oil change so I did that and no change. I'm getting a bucking at low rpm's. If I'm going 25 in 4th or 35-40 in 5th it will buck like crazy. What do you guys think? '09 LT XFE, no engine mods other than K&N drop in.

kmac is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-11-2013, 05:28 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
More than likely the sensor is good since it's giving you a code. The cam actuator need proper viscosity to keep running properly if you wait too long between oil changes you take the chance of contaminating the cam actuators. Oil treatment might free it but you might have to change it eventually.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 5 (permalink) Old 08-12-2013, 06:32 AM
Veteran
 
i944scania's Avatar
 
Join Date: Jul 2012
Location: New Hampshire
Posts: 563
Garage
try a bottle of lucas first

07 LSJ turbo swap
-to4e 50 trim .63 a/r @ 19psi
-2.5" intercooler system with zzp bov
-2.5" exhaust
-turbonetics deltagate II w/voodoo boost controller
-3" intake
-siemens #60s
-aem uego wideband afr
-HP custom tune


i944scania is offline  
 
post #4 of 5 (permalink) Old 08-12-2013, 02:06 PM Thread Starter
Staff Alumni


 
kmac's Avatar
 
Join Date: Jun 2012
Location: Coxsackie, NY
Posts: 297
Alright, sounds good, I'll get the oil treatment. Does it make a difference that the car has only ever had synthetic in it?

kmac is offline  
post #5 of 5 (permalink) Old 08-12-2013, 02:20 PM
Super Moderator
Staff Alumni
YourCobalt of the Month Winner


 
Blackbalts's Avatar
 
Join Date: Aug 2011
Location: Burnsville, Minnesota
Posts: 5,481
Garage
No.


05 Mitsubishi Evolution 8
05 Chevy Cobalt LS (RIP 7/13/2013)
99 Nissan Altima GXE (Daily)
99 Subaru Legacy (Daily)
07 Jeep Liberty Limited (No longer the tow truck for the balt )

If you have questions and I'm not on please PM, notifications go straight to my phone 24/7.

My Showoff
Join YC on FB
Syndicate of Tuners.com
Blackbalts is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome