09 2.2 Ls Throwing Up Too Many Codes to Be Coincidence. - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 08-12-2013, 07:04 PM Thread Starter
Forum Regular
 
Tokymaru's Avatar
 
Join Date: Feb 2013
Posts: 91
09 2.2 Ls Throwing Up Too Many Codes to Be Coincidence.

My 09 ls seems to be throwing up too many codes for everything here to be going wrong at once.
I had a tire separate, and it took the inner fender with it. When I pulled over, it was wrapped around the axle/ suspension. Nothing looked damaged so I put the spare on and drove home. Everything seems fine, but, but about a day after I put new rims and tries on it a few days later (it was already planned, so I wasn't too bent out of shape about the separated tire) it started throwing up trouble codes left and right. I tried resetting the ecm and they come back as soon as the car starts moving again.
O'Reily's didn't give me the specific codes I had, but had mentioned the o2 sensors and the maf. I dug out my pos obdII scanner and got the codes, but it doesnt show the last digit of each, but from reading through the list of dtcs, it looks like they're;
P0031, P0032, P0051, P0052, P010?, P013?, P014?, and P044?
Would the tire have anything to do with this, maybe having knocked a ground wire loose or something? Could all these things really be wrong, or is there just a simple solution(hopefully). I need to get this taken car of, my inspection is up this month, and I can't get it inspected until there's not CEL.
Tokymaru is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 08-12-2013, 07:30 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Looks like you blew the Exhaust voltage fuse. Check in the underhood fuseblock. This fuse supplies voltage to the HO2s and MAF sensor plus a few others like MAP and intake temp


Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly

Last edited by Coby7; 08-12-2013 at 07:34 PM.
Coby7 is offline  
post #3 of 19 (permalink) Old 08-12-2013, 09:06 PM Thread Starter
Forum Regular
 
Tokymaru's Avatar
 
Join Date: Feb 2013
Posts: 91
Quote:
Originally Posted by Coby7 View Post
Looks like you blew the Exhaust voltage fuse. Check in the underhood fuseblock. This fuse supplies voltage to the HO2s and MAF sensor plus a few others like MAP and intake temp

I had read that on another site. I thought I had checked all the fuses before, but I guess I missed that one. Went out to double check, saw it was blown. reset the ecm and let it run for a few minutes. Seems to be working now. I have to go pick up my fiance from work here in about half an hour. Will report whether the MIL comes back on.
Thank you for the help.

---------- Post added at 11:06 PM ---------- Previous post was at 10:01 PM ----------

Well, down the road and back and no codes. Thank you Coby for that bit of knowledge which has potentially saved me a ton of money.
Tokymaru is offline  
 
post #4 of 19 (permalink) Old 08-12-2013, 10:10 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
"You just saved a bunch of money on your mechanic bill by switching to forums"

Sent from AutoGuide.com Free App

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #5 of 19 (permalink) Old 08-22-2013, 03:30 PM
Newcomer
 
Join Date: Aug 2013
Posts: 7
electrical problem!
wont turn over,
fuel gadge wont read
low fuel warning
powersteering warning
battery is fine conections fine
im wondering what is incharge of fuel sending/reading
ECM- tryed a used one fuel still wont read (NO CHANGE
TCM- in mail will arive in few days
BCM- looking for a cheap new one


trying to figure it out before i take it to the dealer I know they will have to program things like ecm, tcm, and bcm
09cobaltsedan is offline  
post #6 of 19 (permalink) Old 08-22-2013, 04:37 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
I think you broke one of the two engine grounds or both, the one in front where the transmission and engine bolt together. This is the ground for TCM and ECM, also for fuel sending unit and a bunch of sensors too.


Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #7 of 19 (permalink) Old 08-22-2013, 05:12 PM
Staff Alumni
 
money_man's Avatar
 
Join Date: Mar 2012
Location: Halifax, N.S
Posts: 3,127
coby is my hero

2009 Ford Escape Limited - 3.0L, 6 speed auto, 4x4, 25/33 city/hwy imp mpg.
2017 F150 XLT-XTR - 5.0L, 4x4, 3.55's, E-locker, xtr chrome package, fx4 off-road package.
20/25 imp mpg
money_man is offline  
post #8 of 19 (permalink) Old 08-22-2013, 07:54 PM
Newcomer
 
Join Date: Aug 2013
Posts: 7
thanks Coby! I will be able to check the ground conect. this weekend
09cobaltsedan is offline  
post #9 of 19 (permalink) Old 08-26-2013, 10:15 AM
Newcomer
 
Join Date: Aug 2013
Posts: 7
Ok so I checked all the grounds and cleaned them, Same problem no change. Car wont turn over fuel gadge wont read, ps warning, abs warning, low fuel warning, any ideas????
should I check if the ECM is getting power? and if so how?????
09cobaltsedan is offline  
post #10 of 19 (permalink) Old 08-26-2013, 10:30 AM
Levee
YourCobalt of the Month Winner
YourCobalt.com Premium Member
Admin


 
Leveecius's Avatar
 
Join Date: Aug 2009
Location: Battle Creek, MI
Posts: 3,210
Garage
Send a message via Yahoo to Leveecius
Checking for power to the ECM is easy. Get the wiring pinout for the ECM, find the power and ground wire and use a volt meter and connect leads, will tell you if you're getting voltage. Sounds like a ground to me, but could be the ECM going out.

'09 SS/TC - Stolen
Mods - Injen CAI, CIA MAF Relocate CP's, Dejon FMIC,
Custom 3" DP, 3" Exhaust, GT3076R, Pioneer AVH-4100DVD, Hurst STS, ZZP triple pod, Autometer Cobalt boost/DPIC/WB gauges, Nitto NT05 245/40/18's, H&R Springs, 80:20 Meth Spray
Future - KSport Kontrol Pro Coilovers, 10% Tint, FMIC spray
538whp/501wtq @38 psi on meth and 93 oct on stock ish motor


06 EVO IX MR/SE - Sold
Mods - *Updated 10/6/13* AEM TRUboost EBC, 4in custom TBE, SD dual 93/e85 tune, ETS 4in Race Core FMIC, Dual Aeromotive 400lph Fuel Pumps, T4 Tubular Manifold w/ dual WG's, FP Super99HTZ DBB Turbo, GSC 274 mivec cams, ARP headstuds/rod studs, FIC 2150cc Injectors, Aeromotive FPR, Aeromotive Fuel Rail, catch can, Mini Battery Kit, Slim Coolant Fan, Kiggly Racing high pressure valve Springs/Titanium Retainers, Supertech Stainless Steel Valves, Dual VTA Tial 44mm WG's, 4g64 Stroker Manley Pistons, 155mm 2.4 LR Manley Turbo Plus I Beam Rods with ARP 625 Studs, 100mm forged non-billet Manley Crankshaft, Full H/E PNP with Port Matching, Kiggly Racing Girdle, Dual Tial 50mm BOV's, Excedy Triple Disc Carbon HD Clutch, AEM EMS

'95 Ram 2500 Diesel
Mods - 5in TBE, Boost Elbow set to 28psi, Adjusted fuel pump, Open Turbo.

Future Mods- Super Street Clutch (rated @1400ftlbs tq), 67mm turbo, 160lb valve springs, added timing, tubular exhaust manifold, larger injectors, possible 6 spd swap.


Master ASE Certified Gasoline/Diesel Technician since 2004

Speed Junkies Social Group

Yourcobalt Official Facebook Page!

Syndicate of Tuners Official Page! Up and going again as of 1/11/13

Click here to PM me if you have questions or issues!
Leveecius is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome