Engine Disabled - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-13-2013, 07:42 PM Thread Starter
Newcomer
 
Join Date: May 2013
Location: Cecil County, MD
Posts: 9
Engine Disabled

Car said engine power reduced then after 1000ft it says engine power disabled. Popped started it and it sounds like it was constantly back firing. The check engine light disappeared after the pop start so when I put it on the computer I got zero codes. I've got gas, brand new plugs I am not sure how to test the spark with the coil pack. The timing chain is not broken but a mechanic friend think it jumped and is now out of time since I am building zero pressure in all but one cylinder where I am getting only 25lbs. You think he is right? It does crank and the throttle body does open when trying to start.

2005 2.2 manual.

Thanks guys!

Last edited by THKbolt; 08-13-2013 at 08:48 PM.
THKbolt is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-13-2013, 08:46 PM
Staff Alumni


 
Jmesl8er's Avatar
 
Join Date: May 2011
Location: NKY
Posts: 1,316
Probably. Same thing happened to mine. Chain jumped. Broke 5 rockers in half. Pull the valve cover and check.
Jmesl8er is offline  
post #3 of 6 (permalink) Old 08-13-2013, 08:53 PM Thread Starter
Newcomer
 
Join Date: May 2013
Location: Cecil County, MD
Posts: 9
Quote:
Originally Posted by Jmesl8er View Post
Probably. Same thing happened to mine. Chain jumped. Broke 5 rockers in half. Pull the valve cover and check.
I'll be checking that tomorrow. Were you able to get away with just replacing the timing chain.
THKbolt is offline  
 
post #4 of 6 (permalink) Old 08-13-2013, 09:28 PM
Staff Alumni


 
Jmesl8er's Avatar
 
Join Date: May 2011
Location: NKY
Posts: 1,316
No, mine is tore up pretty bad. Like I said, it broke rockers in half. I still have to pull the head and see if there is anymore damage done.
Jmesl8er is offline  
post #5 of 6 (permalink) Old 08-13-2013, 09:57 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Check your oil to see if any gas is in there also. If not, that rules out your rings. But as james said, you probably jumped timing. I would pull your valve cover and push on all rockers to make sure they don't move. If they seem fine, I would buy a new timing kit and see what that does for you

Sent from AutoGuide.com Free App

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #6 of 6 (permalink) Old 08-14-2013, 06:44 AM Thread Starter
Newcomer
 
Join Date: May 2013
Location: Cecil County, MD
Posts: 9
Quote:
Originally Posted by BankerBalt View Post
Check your oil to see if any gas is in there also. If not, that rules out your rings. But as james said, you probably jumped timing. I would pull your valve cover and push on all rockers to make sure they don't move. If they seem fine, I would buy a new timing kit and see what that does for you

Sent from AutoGuide.com Free App
Yea I'll be checking that today. When I pulled the valve cover off yesterday everything looked good. Checking and the rockers and valves today
THKbolt is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome