Cam Sensor Issue - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-14-2013, 08:19 AM Thread Starter
Newcomer
 
Join Date: Sep 2013
Posts: 3
Cam Sensor Issue

I have a 07 cobalt, 2.2 engine. About a week ago the check engine light came on. Hooked up a scanner and the codes recieved were P0340 and P0341, which are related to the cam sensor. I went into my local auto zone to buy the sensor, the sales guy told me the car requires two, but he could only find one on the diagram. I bought the two, replaced one thats beneath the oil cap, but I cant find the other. Does anyone know where it is, or if the car even requieres two?
dscobalt is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-14-2013, 08:41 AM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
There's a crank positioner sensor by the starter. There's one cam sensor pressed on the intake cam and the one by the oil cap that correlates with the intake cam

Sent from AutoGuide.com Free App

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #3 of 3 (permalink) Old 09-14-2013, 08:48 AM
Chevy Customer Service
YourCobalt.com Premium MemberExpert
 
ChevyCustSvc's Avatar
 
Join Date: Nov 2010
Location: Detroit, Michigan USA
Posts: 794
dscobalt,

If you still can't locate this, I can certainly check with my internal resources. I would need you to provide me with the last 8 digits of your VIN.

Erica Tiffany
Chevrolet Customer Care

Have you checked into Chevrolet Owner Center? You can maintain service history, check on warranty or recall information, and more. Visit my.chevrolet.com!
ChevyCustSvc is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome