Mass Air Flow Sensor - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 10-12-2013, 04:29 AM Thread Starter
Forum Regular
 
Macky91's Avatar
 
Join Date: Jan 2013
Location: tulsa ok
Posts: 102
Garage
Unhappy Mass Air Flow Sensor

hey guys i just recently installed a spider cold air intake, and my check engine light came on stating mass air flow sensor or air volume low.
i cleared the code and 10 minuts later it poped back up again.
Is the reason its coming up with this code bc of the volume of the air is not the normal volume? the difference between stock intake and cold air intake?

Note: the cold air intake i intalled went down in my front bumper replacing my silencer.
Macky91 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 10-12-2013, 04:38 AM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Where is the maf located on the pipe?

Sent from AutoGuide.com Free App

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #3 of 9 (permalink) Old 10-12-2013, 04:51 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
You may have a leak or sensor may not be in far enough.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
 
post #4 of 9 (permalink) Old 10-12-2013, 05:20 AM Thread Starter
Forum Regular
 
Macky91's Avatar
 
Join Date: Jan 2013
Location: tulsa ok
Posts: 102
Garage
The sensor is closer to the throttle body,
and when i get time il double check everything nd i have cleaner for it as well.
it was kinna a hassel to install but i notice a difference on how she runs.
Macky91 is offline  
post #5 of 9 (permalink) Old 10-12-2013, 06:42 AM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
My suggestion is move it at least a foot away from the throttle body

Sent from AutoGuide.com Free App

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #6 of 9 (permalink) Old 10-12-2013, 06:55 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Quote:
Originally Posted by Macky91 View Post
I noticed a difference on how she runs.
She will sure run differently if the MAF can't do its job, probably run rich.

---------- Post added at 10:55 AM ---------- Previous post was at 10:54 AM ----------

Do you have pictures of your install?

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #7 of 9 (permalink) Old 10-12-2013, 07:13 AM Thread Starter
Forum Regular
 
Macky91's Avatar
 
Join Date: Jan 2013
Location: tulsa ok
Posts: 102
Garage
ok i cant move it but il look over the pipe and connections, and clean it.
Macky91 is offline  
post #8 of 9 (permalink) Old 10-12-2013, 07:25 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Also make sure you didn't flip airflow direction of "MAF"

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #9 of 9 (permalink) Old 10-14-2013, 05:50 AM Thread Starter
Forum Regular
 
Macky91's Avatar
 
Join Date: Jan 2013
Location: tulsa ok
Posts: 102
Garage
I ended up reworking the pipe and adjusting it and the code cleared now my O2 sensor is bad... lol
Macky91 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome