2007 Cobalt Airbag Issues - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-05-2013, 08:27 AM Thread Starter
Newcomer
 
Join Date: Jan 2013
Location: Endicott, NY
Posts: 7
Question 2007 Cobalt Airbag Issues

Hi folks! I've got a problem with my wife's 2007 Cobalt LS (base model, I think it's LS). A while ago the service airbag message came up on the driver display. I took it to the dealership where we bought the car (not a Chevy dealer, it was used) and they replaced the clockspring.

A few months later, the service airbag message comes up again. As the warranty is now up, I take it to the local Chevy dealership. They read the codes (charging me $80) and tell me the clockspring is bad. This time I replace it myself. I take it back (to a different dealer) to have the codes cleared and they tell me now it is the wiring or connector to the clockspring. I take the wiring all apart and find where 2 airbag wires were pinched in the tilt mechanism (likely threw the clockspring code too) and repair the wires. I take it back to the dealer again and this time they say the front airbag impact sensor is bad. I haven't replaced it yet as it is pricey ($200).

But my question is this, why can't I get a straight answer on the problem and how the heck am I supposed to test these parts? I can't find any info on trying to diagnose and repair it myself. Oh and this car has 45,000 miles on it. Something has to be wrong, NOTHING should wear out in 45,000 miles except brakes and tires.

Dude! Where's my signature!
OdieTurbo is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-05-2013, 08:48 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Dealers do that all the time, I bought my own TechII since I own 4 GMs. I don't believe for one second that your front airbag sensor is bad. Just disconnect it clean the connector contacts and reconnect. OH! disconnect battery first.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 5 (permalink) Old 11-17-2013, 07:36 AM Thread Starter
Newcomer
 
Join Date: Jan 2013
Location: Endicott, NY
Posts: 7
Quote:
Originally Posted by Coby7 View Post
Dealers do that all the time, I bought my own TechII since I own 4 GMs. I don't believe for one second that your front airbag sensor is bad. Just disconnect it clean the connector contacts and reconnect. OH! disconnect battery first.
That sounds easy enough... where is the front airbag sensor?

Dude! Where's my signature!
OdieTurbo is offline  
 
post #4 of 5 (permalink) Old 11-17-2013, 10:06 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
It is almost in the middle of the top radiator support bracket, engine side.


Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly

Last edited by Coby7; 11-17-2013 at 10:44 AM.
Coby7 is offline  
post #5 of 5 (permalink) Old 11-17-2013, 12:22 PM Thread Starter
Newcomer
 
Join Date: Jan 2013
Location: Endicott, NY
Posts: 7
Thanks! I found it and removed it to check the wiring connections. It looks brand new! I'm gonna have to buy the cable and software to diagnose this thing.

Dude! Where's my signature!
OdieTurbo is offline  
Sponsored Links
Advertisement
 
Closed Thread

Tags
airbag

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome