Rear Defroster Grid Bad? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-17-2013, 10:04 PM Thread Starter
Newcomer
 
Join Date: Jul 2013
Posts: 1
Rear Defroster Grid Bad?

I have read some of the threads. I have power at the grid but not across the grid lines. I visually inspected the grid and didn't see any scratches or breaks. The car has had tint put on removed and then put on again. What else can I do before thinking I have to get a new rear window to have rear defrost again? Any help will be appreciated! I did remove the current tint so i could get to the grid lines.
stang0303 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-19-2013, 07:13 PM
Initiate
 
Join Date: May 2011
Posts: 45
I had an issue with mine. If I pulled the positive side plug from the grid and measure the voltage it was right around 12v. As soon as I would plug it into the grid, it was <3 volts. Turns out that the line from the relay melted in the connector under the rear dash panel. I fixed that and now the rear defroster works. I don't know if you have a similar issue. The other thing I would check is to make sure that the passenger side connector is grounded.
Racer is offline  
post #3 of 5 (permalink) Old 11-19-2013, 08:58 PM
Forum Regular
 
Robsp32's Avatar
 
Join Date: Oct 2013
Posts: 106
Thats a common problem when tint is removed incorrectly. They sell a silver pen that you use to reconnect the traces at the break points.
Robsp32 is offline  
 
post #4 of 5 (permalink) Old 11-20-2013, 09:52 AM
Cobalt Specialist
 
JacksonWilder3's Avatar
 
Join Date: May 2012
Location: Wasilla, Alaska
Posts: 1,067
He said there was no visible break points though


2010 Cobalt 2LT Sports Package
2.5% tint all the way round.
SUPRRAAACHARRRGGEDDD
2.9 pulley, 60# Injectors, Injen 2.5" intake
55 Watt 6000K Hi/Lo HID's
35 Watt 5000K Fogs
Black SS 17" Wheels
Debadged
Spyder 3" Carbon Fiber Antenna
YAKIMA ROOF RACK WITH 40" LIGHTBAR
2.5' ZZP DP
Full set of Black Recaros
Eibach sportlines for teh low.
Front and rear SS lips
JacksonWilder3 is offline  
post #5 of 5 (permalink) Old 11-20-2013, 10:33 AM
Forum Regular
 
Robsp32's Avatar
 
Join Date: Oct 2013
Posts: 106
they dont have to be visible, just run the pen down one of the center ones and see if it reconnects.
Robsp32 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome