Help for Cel/advice As Well - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 12-01-2013, 04:13 PM Thread Starter
Forum Regular
 
Join Date: Jun 2012
Posts: 97
Help for Cel/advice As Well

Hey guys, need some help.. My 09 Cobalt LT Sedan with 85k miles and automatic tranny, backed out of a driveway, kinda steep incline and had to give it a little more gas to get er up onto the road, bout a mile after I'm driving it idled kinda rough then Check Engine light came on. Advance auto hooked it up and it read it was the Camshaft pos. Sensor. Car seems to run OK now, light still on. Does this mean jumped timing? Is this serious? Or just a damn sensor gone bad.
greenbalt03 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 12-01-2013, 04:15 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Cel could have just tripped. Delete the code and see if it comes back. If it does, replace the solenoid

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #3 of 8 (permalink) Old 12-01-2013, 04:21 PM Thread Starter
Forum Regular
 
Join Date: Jun 2012
Posts: 97
OK if its the solenoid, what is the exact description I ask for ? Camshaft Position Sensor Solenoid? And the Advance Auto reader tool and guy, told me the car has a history of this code reoccurring. Its been cleared bout three times. Should I be worried about that ? Thanks.
greenbalt03 is offline  
 
post #4 of 8 (permalink) Old 12-01-2013, 04:38 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Did you check for silent recalls? The early 2009 had these problems due to engine assembly process. Some of these cam actuators were replaced by GM.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #5 of 8 (permalink) Old 12-02-2013, 04:22 PM
Chevy Customer Service
YourCobalt.com Premium MemberExpert
 
ChevyCustSvc's Avatar
 
Join Date: Nov 2010
Location: Detroit, Michigan USA
Posts: 794
Quote:
Originally Posted by greenbalt03Hey guys, need some help.. My 09 Cobalt LT Sedan with 85k miles and automatic tranny, backed out of a driveway, kinda steep incline and had to give it a little more gas to get er up onto the road, bout a mile after I'm driving it idled kinda rough then Check Engine light came on. Advance auto hooked it up and it read it was the Camshaft pos. Sensor. Car seems to run OK now, light still on. Does this mean jumped timing? Is this serious? Or just a damn sensor gone bad.
Hi greenbbalt03,

Sorry to hear that you're having some trouble with your Cobalt. If you want to send us your VIN, we can look into any warranty and recall information for your vehicle possibly relating to this issue. If there's anything we can do to help, please let us know.

Amber N.
Chevrolet Customer Care

Have you checked into Chevrolet Owner Center? You can maintain service history, check on warranty or recall information, and more. Visit my.chevrolet.com!
ChevyCustSvc is offline  
post #6 of 8 (permalink) Old 12-13-2013, 09:47 PM Thread Starter
Forum Regular
 
Join Date: Jun 2012
Posts: 97
Hey guys going to Dealer tomorrow, hoping to get my car fixed . Was told it may be under warranty since im under 100k miles. Will tell ya the outcome. My light has been on one day n runnin rough n next day lights been off n car runs fine. Of course, now that im taking it in tomorrow, the lights off. Ugh. Still runs rough at times tho. LOL.
greenbalt03 is offline  
post #7 of 8 (permalink) Old 12-14-2013, 02:32 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Let us know how your dealer treats you and how it turns out.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #8 of 8 (permalink) Old 12-14-2013, 09:21 PM Thread Starter
Forum Regular
 
Join Date: Jun 2012
Posts: 97
Hello hello, well turns out it was my intake cam actuator solenoid thing a muh hobber. It was all free and considered part of the emissions warranty. While it was there i figured id get an alignment done ( which was not free) and my car seems a lot better. The dealer service writer was nice although kept pointing out that my exhaust would void my warranty if the problem i had was exhaust related.
Yes im aware of that i told him. And he was cool about it except for brining mods up fifty times. My mods are ebay exhaust, k&n drop in filter and air box mod, eibach springs n thats it. So anyhoo, im just glad my car repair was free and its rolljng str8 again.

---------- Post added at 12:21 AM ---------- Previous post was at 12:17 AM ----------

BTW thanks for ur help guys. I really appreciate all the help you guys provide on here.
greenbalt03 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome