2006 2.2 LS Manual Cold Start Issue - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 12-09-2013, 10:17 AM Thread Starter
Initiate
 
Join Date: Feb 2012
Location: South Carolina
Posts: 41
2006 2.2 LS Manual Cold Start Issue

I live in South Carolina so it's not like its -20 degrees or anything. However, when it's about 30-45 degrees in the AM, when I try to start cobalt it starts and dies. It will rev up for a sec and then fall flat on its face. I can give it some gas, like a cold natured carb and sometimes get it to rev up and stay running. This morning it died like 10 times before I could get it to stay running!

I have check engine lights, but advanced scanner can't read them. I'm sure I have power to obdII because my little plug in insurance thing I have to save some $$ works. Originally when I bought the car it had bad cat code, replaced o2 sensors and didn't fix anything.

2006 cobalt 2.2 manual 2 door LS. 99,xxx miles.
Shealy06 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 12-09-2013, 10:33 AM
Super Moderator
 
swanman35's Avatar
 
Join Date: May 2013
Location: SWPA
Posts: 2,068
Recently my car wasn't starting at all unless I let ithe key on the "on" position for a second, I had a hole in my gas line. Check under the vehicle and make sure there is no leak. This may not be the solution but it's a start lol

Sent from AutoGuide.com Free App
swanman35 is offline  
post #3 of 14 (permalink) Old 12-09-2013, 10:41 AM Thread Starter
Initiate
 
Join Date: Feb 2012
Location: South Carolina
Posts: 41
I actually parked on top of cardboard all last week after I replaced thermostat and drained coolant. No leaks as of yet. Thank god!!!
Shealy06 is offline  
 
post #4 of 14 (permalink) Old 12-09-2013, 12:03 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Clean your throttle body, run injector cleaner through it, replace your fuel filter

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #5 of 14 (permalink) Old 12-09-2013, 12:26 PM
Super Moderator
 
swanman35's Avatar
 
Join Date: May 2013
Location: SWPA
Posts: 2,068
When was the last spark plug change?

Sent from AutoGuide.com Free App
swanman35 is offline  
post #6 of 14 (permalink) Old 12-09-2013, 01:14 PM Thread Starter
Initiate
 
Join Date: Feb 2012
Location: South Carolina
Posts: 41
Spark plugs and fuel filter changed 1 year 6 months ago.

Ran FI cleaner last oil change 200 miles ago.

Clean TB is a good idea. I know I need new air filter.

It's like the "choke" isn't working. Like bad coolant temp sens not adjusting for cold temps and not dumping more fuel at startup.

I've read about "cat warmer" not functioning correctly??

Gas mileage hasn't changed. Still 38 when warm weather and 36 during winter months.

I have noticed it runs a little rich on startup when warm, when I backup I normally can smell fuel.

Last edited by Shealy06; 12-09-2013 at 01:29 PM.
Shealy06 is offline  
post #7 of 14 (permalink) Old 12-09-2013, 01:22 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Check compression

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #8 of 14 (permalink) Old 12-09-2013, 01:30 PM Thread Starter
Initiate
 
Join Date: Feb 2012
Location: South Carolina
Posts: 41
Check compression? What's reasoning behind that suggestion?
Shealy06 is offline  
post #9 of 14 (permalink) Old 12-09-2013, 02:28 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Spark advance will get it started but the piston rings may not be making a good seal when they are cold. Its just a thought if you've tried everything else mentioned

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #10 of 14 (permalink) Old 12-09-2013, 03:19 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
What are the codes? Maybe your purge solenoid is stuck open.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome