Car Acting Strange! - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-20-2013, 06:25 PM Thread Starter
Prospect
 
Join Date: Sep 2013
Posts: 11
Car Acting Strange!

So today as I was leaving the parking lot from work my car started jerking as I came to a stop like it wanted to die or wasn't getting enough gas. I immediately pulled into a spot and turned my car off for a few minutes. I tried turning it back on and it acted like it didn't want to start so i turned it off then tried again and it started just fine and drove fine after that. On the way home I had onstar run a diagnostics check and no codes came back so i have no idea what could possibly be the problem. Where I park at work is on a slight decline but I had a little over a quarter of a tank and this has never happened before so I don't think it could be from that. Also my car is a 2009, has a little over 51k miles on it and all maintenance has been kept up on it.

Last edited by tdan; 12-20-2013 at 06:42 PM.
tdan is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-20-2013, 07:03 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Clean your throttle body...

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 4 (permalink) Old 12-20-2013, 07:12 PM Thread Starter
Prospect
 
Join Date: Sep 2013
Posts: 11
Ok thanks! Gonna take it in on monday to get checked out and hopefully get the problem resolved.
tdan is offline  
 
post #4 of 4 (permalink) Old 12-20-2013, 10:02 PM
Prospect
 
Join Date: Jan 2013
Posts: 10
Mine was having a rough idle after slowing down from speed and occasionally stalling. Cleaned the TB and no issues since.
Newtothis is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome