Help - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 12-20-2013, 06:35 PM Thread Starter
Newcomer
 
Join Date: Dec 2013
Posts: 2
Help

I have a 2009 cobalt and I recently hit a raccoon causing my radiator to crack and my engine to overheat. I didnt realize that I had a crack but did have the cooling mode on flashing at me on the dash. I kept driving the car after a put a gallon on coolant in it. I drove it hot for another few miles and the car started losing power then just stopped and hasn't started sense. When I the. The key the timing chain spins and is cranking but the car just doesn't turn over. The oil is not milky indicating a blown gasket, but the engine just won't start. I have changed the cam sensor and all my spark plugs, but the car still won't fire. Any ideas? A mechanic has said that the car is turning but it just isnt firing. So idk what the problem is. The oil is a little low also it is a little burnt but nothing too terrible.
tiffanyscobalt is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 12-20-2013, 08:20 PM
Veteran
 
Batmobile's Avatar
 
Join Date: Apr 2011
Location: Western Maryland
Posts: 658
Garage
You have replaced the radiator right?
Batmobile is offline  
post #3 of 10 (permalink) Old 12-21-2013, 12:04 AM
Cobalt Specialist
 
Dustinb855's Avatar
 
Join Date: Jun 2013
Location: Westminster, CO
Posts: 1,373
One thing that I hate about cobalts. Why dont they have any guards to protect the radiator???
Dustinb855 is offline  
 
post #4 of 10 (permalink) Old 12-21-2013, 05:44 AM
Cobalt Specialist


 
Join Date: Jun 2011
Location: Charlotte, NC
Posts: 1,145
Your talking about a radiator shroud?

2009 Cobalt LS XFE U74
Mods: K&N Typhoon Intake, Option Cat-Back Exhaust, Cosmo Short shifter, Maxxim Ahead 17X7's, MPx shorty antenna, FE5 Strut/shocks, Tein S Techs, Moog endlinks, Moog spring seaters, ZZP shorty header, LSJ downpipe, LNF front grille
5t3alth is offline  
post #5 of 10 (permalink) Old 12-21-2013, 07:02 AM
Levee
YourCobalt of the Month Winner
YourCobalt.com Premium Member
Admin


 
Leveecius's Avatar
 
Join Date: Aug 2009
Location: Battle Creek, MI
Posts: 3,210
Garage
Send a message via Yahoo to Leveecius
A milky oil isnt the only thing that indicates a blown head gasket. You could have enoigh coolant in your cylinders to foul out the plugs. Pull the spark plugs out and shine a flashlight down the spark plug hole into the cylinder. See if you have a lot of coolant in there.

With the loss of power and then just stopping, it sounds to me like the head gasket popped.

---------- Post added at 10:02 AM ---------- Previous post was at 09:58 AM ----------

But as far as it not starting, there could be a lot of things that would cause it not to start : CPS, CAS, ICM, couls, timing,vacuum leak, bad plugs, cracked engine parts, burnt/melted wiring, ect.

'09 SS/TC - Stolen
Mods - Injen CAI, CIA MAF Relocate CP's, Dejon FMIC,
Custom 3" DP, 3" Exhaust, GT3076R, Pioneer AVH-4100DVD, Hurst STS, ZZP triple pod, Autometer Cobalt boost/DPIC/WB gauges, Nitto NT05 245/40/18's, H&R Springs, 80:20 Meth Spray
Future - KSport Kontrol Pro Coilovers, 10% Tint, FMIC spray
538whp/501wtq @38 psi on meth and 93 oct on stock ish motor


06 EVO IX MR/SE - Sold
Mods - *Updated 10/6/13* AEM TRUboost EBC, 4in custom TBE, SD dual 93/e85 tune, ETS 4in Race Core FMIC, Dual Aeromotive 400lph Fuel Pumps, T4 Tubular Manifold w/ dual WG's, FP Super99HTZ DBB Turbo, GSC 274 mivec cams, ARP headstuds/rod studs, FIC 2150cc Injectors, Aeromotive FPR, Aeromotive Fuel Rail, catch can, Mini Battery Kit, Slim Coolant Fan, Kiggly Racing high pressure valve Springs/Titanium Retainers, Supertech Stainless Steel Valves, Dual VTA Tial 44mm WG's, 4g64 Stroker Manley Pistons, 155mm 2.4 LR Manley Turbo Plus I Beam Rods with ARP 625 Studs, 100mm forged non-billet Manley Crankshaft, Full H/E PNP with Port Matching, Kiggly Racing Girdle, Dual Tial 50mm BOV's, Excedy Triple Disc Carbon HD Clutch, AEM EMS

'95 Ram 2500 Diesel
Mods - 5in TBE, Boost Elbow set to 28psi, Adjusted fuel pump, Open Turbo.

Future Mods- Super Street Clutch (rated @1400ftlbs tq), 67mm turbo, 160lb valve springs, added timing, tubular exhaust manifold, larger injectors, possible 6 spd swap.


Master ASE Certified Gasoline/Diesel Technician since 2004

Speed Junkies Social Group

Yourcobalt Official Facebook Page!

Syndicate of Tuners Official Page! Up and going again as of 1/11/13

Click here to PM me if you have questions or issues!
Leveecius is offline  
post #6 of 10 (permalink) Old 12-21-2013, 08:55 AM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Probably warped the head. Could have seized if starter wont turn

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #7 of 10 (permalink) Old 12-21-2013, 10:25 AM Thread Starter
Newcomer
 
Join Date: Dec 2013
Posts: 2
I have replaced the radiator.. also the cam sensor. I just don't understand why the engine will crank but won't fire..
tiffanyscobalt is offline  
post #8 of 10 (permalink) Old 12-21-2013, 10:39 AM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Plugs? Getting spark? Getting fuel? Maf sensor in tact?

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #9 of 10 (permalink) Old 12-21-2013, 10:52 AM
Levee
YourCobalt of the Month Winner
YourCobalt.com Premium Member
Admin


 
Leveecius's Avatar
 
Join Date: Aug 2009
Location: Battle Creek, MI
Posts: 3,210
Garage
Send a message via Yahoo to Leveecius
Re-read my response.

'09 SS/TC - Stolen
Mods - Injen CAI, CIA MAF Relocate CP's, Dejon FMIC,
Custom 3" DP, 3" Exhaust, GT3076R, Pioneer AVH-4100DVD, Hurst STS, ZZP triple pod, Autometer Cobalt boost/DPIC/WB gauges, Nitto NT05 245/40/18's, H&R Springs, 80:20 Meth Spray
Future - KSport Kontrol Pro Coilovers, 10% Tint, FMIC spray
538whp/501wtq @38 psi on meth and 93 oct on stock ish motor


06 EVO IX MR/SE - Sold
Mods - *Updated 10/6/13* AEM TRUboost EBC, 4in custom TBE, SD dual 93/e85 tune, ETS 4in Race Core FMIC, Dual Aeromotive 400lph Fuel Pumps, T4 Tubular Manifold w/ dual WG's, FP Super99HTZ DBB Turbo, GSC 274 mivec cams, ARP headstuds/rod studs, FIC 2150cc Injectors, Aeromotive FPR, Aeromotive Fuel Rail, catch can, Mini Battery Kit, Slim Coolant Fan, Kiggly Racing high pressure valve Springs/Titanium Retainers, Supertech Stainless Steel Valves, Dual VTA Tial 44mm WG's, 4g64 Stroker Manley Pistons, 155mm 2.4 LR Manley Turbo Plus I Beam Rods with ARP 625 Studs, 100mm forged non-billet Manley Crankshaft, Full H/E PNP with Port Matching, Kiggly Racing Girdle, Dual Tial 50mm BOV's, Excedy Triple Disc Carbon HD Clutch, AEM EMS

'95 Ram 2500 Diesel
Mods - 5in TBE, Boost Elbow set to 28psi, Adjusted fuel pump, Open Turbo.

Future Mods- Super Street Clutch (rated @1400ftlbs tq), 67mm turbo, 160lb valve springs, added timing, tubular exhaust manifold, larger injectors, possible 6 spd swap.


Master ASE Certified Gasoline/Diesel Technician since 2004

Speed Junkies Social Group

Yourcobalt Official Facebook Page!

Syndicate of Tuners Official Page! Up and going again as of 1/11/13

Click here to PM me if you have questions or issues!
Leveecius is offline  
post #10 of 10 (permalink) Old 12-21-2013, 11:05 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Check all the fuses related to engine, especially ignition 1 voltage.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome