Radio/Dash Problem - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-03-2014, 09:38 PM Thread Starter
Newcomer
 
Join Date: Mar 2011
Posts: 5
Radio/Dash Problem

Hello all,

I have a 2008 Cobalt LS with basic radio, no on star or anything fancy. I was out of the country for a month and basically left my car sitting at my work and we had lots of extremely cold weather/snow and such. The problem I had as soon as i got back was that my radio does not work. The back light on the buttons will come on for a moment, and go right back off. if i hit the Information button it will display the time and if a CD is in. I can press the eject button and a CD will come out but nothing else. I had something similar to this problem before where the display was kinda scrambled and it fixed itself (this happened in cold weather as well, i assumed they were related). Now i noticed something else. when i start the car it takes like 10 seconds before i get my gas tank level/rpm reading/mileage, etc....I will get all ------------ before that info is displayed. When starting the car the ---------- will come on until the backlight on the radio is on, once the radio comes on i get my readings. I read online somewhere that all that crap is tied into a bus system (GM LAN or something). am i wrong for thinking that the car is looking for the stereo system before the readings come on, and the radio which is half working finally somewhat powers on and voila you get the readings on the dash? any help is appreciated. thanks
mwhited07 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-06-2014, 07:10 PM Thread Starter
Newcomer
 
Join Date: Mar 2011
Posts: 5
was the radio, guess it finally took a dump, replaced with a new head unit.
mwhited07 is offline  
post #3 of 3 (permalink) Old 02-07-2014, 03:30 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Your radio might be dragging down the GMLan circuit. Try pulling the radio fuse to see if your DIC reacts differently.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome