'08 Cobalt Coolant? Problem - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 04-03-2014, 06:39 PM Thread Starter
Prospect
 
Join Date: Dec 2009
Posts: 13
'08 Cobalt Coolant? Problem

Hey folks, been awhile. The other day wife is driving home from work, AC stops cooling all of a sudden, AC dash lights stayed on, just air got warm. Next day driving to work, "engine" light is on, she scrolled through info, coolant reads nothing. Her boss checked under the hood, sees coolant reservoir is low, adds about a cup he says of coolant, later I find out this was 50/50 GREEN.(EG) I drained the system today & poured through distilled water, then closed & filled eith 50/50 DEXCOOL. Ran the motor & heat/defrost for awhile thinking the engine would suck it in at some point & I could top off reservoir. After about 45 minutes or more, I gave up, reservoir never droped & hose was just a little warm. Radiator fan ran the entire time, I thought it was supposed to go on & off, never stopped. Sorry if I is ignant, just trying to keep the work vehicle running? Any thoughts from the Cobalt pros? TIA
45auto is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 04-03-2014, 07:16 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Whats the code for? Its either your thermostat or your temp sensor. Both cheap and easy fixes

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #3 of 15 (permalink) Old 04-04-2014, 08:42 PM Thread Starter
Prospect
 
Join Date: Dec 2009
Posts: 13
Code is P0128, says thermostat, is that definitely it? Shows dashes in "---" in coolant display (DIC). Thanks for the thoughts BB.

Last edited by 45auto; 04-04-2014 at 08:44 PM.
45auto is offline  
 
post #4 of 15 (permalink) Old 04-05-2014, 08:05 AM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Replace thermo and temp sensor

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #5 of 15 (permalink) Old 04-05-2014, 08:54 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Check the connection to the temperature sensor first. Chances are thermostat is still good.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #6 of 15 (permalink) Old 04-05-2014, 10:47 AM Thread Starter
Prospect
 
Join Date: Dec 2009
Posts: 13
Believe you're right C7, replaced thermostat, no change. Going to replace sensor now. Would sensor make radiator fan run when starting the engine?
45auto is offline  
post #7 of 15 (permalink) Old 04-05-2014, 11:00 AM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Yes it is a caution measure the car takes when it doesnt know how warm it is

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #8 of 15 (permalink) Old 04-05-2014, 01:28 PM Thread Starter
Prospect
 
Join Date: Dec 2009
Posts: 13
Well, after install of coolant temp sensor, ran the engine for awhile with defrost, DIC coolant temp started working, & AC cooled again.(YEA!) Took it for an extended test drive on city streets & the freeway, temp never exceeded 199f with defrost on. Seems to be ok. Tried to clear codes to turn off engine light, but is still on. Will if go off by itself?
45auto is offline  
post #9 of 15 (permalink) Old 04-05-2014, 01:59 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Could be another code. Did you actually use a scanner to delete?

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #10 of 15 (permalink) Old 04-05-2014, 02:09 PM Thread Starter
Prospect
 
Join Date: Dec 2009
Posts: 13
used an sct mustang tuner. Went ahead * checked for codes again, now shows P0128 & P0118...

Last edited by 45auto; 04-05-2014 at 02:50 PM.
45auto is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome