Misfire at 5,200 Rpm. 09 2.2l Ls 5spd - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 22 (permalink) Old 04-23-2014, 10:39 AM Thread Starter
Prospect
 
mighty mouse's Avatar
 
Join Date: Apr 2014
Location: pittsburgh pa
Posts: 26
Misfire at 5,200 Rpm. 09 2.2l Ls 5spd

When doing any merging,passing right at 5,200 rpm my cel starts flashing. I've checked n changed plugs. moved ignition coils n tried fuel system treatment. For now I just don't go near 5,000 rpm n I still get 30mpg n No Other codes. I'm stumped. any help suggestions? Thanks.
mighty mouse is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 04-23-2014, 10:47 AM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Do a compression test. However, my assumption is a coil pack or injector. It doesnt give you a specific cylinder after it stops flashing?

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #3 of 22 (permalink) Old 04-23-2014, 11:50 AM Thread Starter
Prospect
 
mighty mouse's Avatar
 
Join Date: Apr 2014
Location: pittsburgh pa
Posts: 26
Sometimes 3. Sometimes a random multiple. allready did compression test. .

---------- Post added at 10:50 AM ---------- Previous post was at 10:27 AM ----------

Thanks for the info. i will try the compression test again with somebody. 1st results may be off as i hooked up gauge n tried to start car. right before it almost started i stopped got out n looked at gauge. All readings were at 130 psi.
mighty mouse is offline  
 
post #4 of 22 (permalink) Old 04-23-2014, 11:51 AM
Levee
YourCobalt of the Month Winner
YourCobalt.com Premium Member
Admin


 
Leveecius's Avatar
 
Join Date: Aug 2009
Location: Battle Creek, MI
Posts: 3,210
Garage
Send a message via Yahoo to Leveecius
What are the specific codes given?

'09 SS/TC - Stolen
Mods - Injen CAI, CIA MAF Relocate CP's, Dejon FMIC,
Custom 3" DP, 3" Exhaust, GT3076R, Pioneer AVH-4100DVD, Hurst STS, ZZP triple pod, Autometer Cobalt boost/DPIC/WB gauges, Nitto NT05 245/40/18's, H&R Springs, 80:20 Meth Spray
Future - KSport Kontrol Pro Coilovers, 10% Tint, FMIC spray
538whp/501wtq @38 psi on meth and 93 oct on stock ish motor


06 EVO IX MR/SE - Sold
Mods - *Updated 10/6/13* AEM TRUboost EBC, 4in custom TBE, SD dual 93/e85 tune, ETS 4in Race Core FMIC, Dual Aeromotive 400lph Fuel Pumps, T4 Tubular Manifold w/ dual WG's, FP Super99HTZ DBB Turbo, GSC 274 mivec cams, ARP headstuds/rod studs, FIC 2150cc Injectors, Aeromotive FPR, Aeromotive Fuel Rail, catch can, Mini Battery Kit, Slim Coolant Fan, Kiggly Racing high pressure valve Springs/Titanium Retainers, Supertech Stainless Steel Valves, Dual VTA Tial 44mm WG's, 4g64 Stroker Manley Pistons, 155mm 2.4 LR Manley Turbo Plus I Beam Rods with ARP 625 Studs, 100mm forged non-billet Manley Crankshaft, Full H/E PNP with Port Matching, Kiggly Racing Girdle, Dual Tial 50mm BOV's, Excedy Triple Disc Carbon HD Clutch, AEM EMS

'95 Ram 2500 Diesel
Mods - 5in TBE, Boost Elbow set to 28psi, Adjusted fuel pump, Open Turbo.

Future Mods- Super Street Clutch (rated @1400ftlbs tq), 67mm turbo, 160lb valve springs, added timing, tubular exhaust manifold, larger injectors, possible 6 spd swap.


Master ASE Certified Gasoline/Diesel Technician since 2004

Speed Junkies Social Group

Yourcobalt Official Facebook Page!

Syndicate of Tuners Official Page! Up and going again as of 1/11/13

Click here to PM me if you have questions or issues!
Leveecius is offline  
post #5 of 22 (permalink) Old 04-23-2014, 11:54 AM Thread Starter
Prospect
 
mighty mouse's Avatar
 
Join Date: Apr 2014
Location: pittsburgh pa
Posts: 26
P0303 n sometimes P0300.
mighty mouse is offline  
post #6 of 22 (permalink) Old 04-23-2014, 12:09 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
P0300 is a multiple misfire. P0303 is kind of misleading on the Cobalt because the ECM throws this out when it doesn't know what the problem is. Does your reader show misfire counts? If you have a P0303 with no misfire counts on cylinder 3 this means you have an O sensor going out of limit, usually sensor #1 upstream. It leans out the engine and you get misfire, actually you get no fire because there is not enough gas. So all this to say my guess is on the first O sensor but I'm no mechanic.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #7 of 22 (permalink) Old 04-23-2014, 02:19 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
To verify it in fact is the o2 sensor, swap #3 coil pack with another one. If the misfire changes cylinders, its a coil pack. If the misfire is still there, swap #3 injector with another. If misfire follows, replace injector. If misfire doesnt follow, id go with coby and get a new o2 sensor. After every step, delete your code so its a fresh code popping back up

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #8 of 22 (permalink) Old 04-23-2014, 04:52 PM Thread Starter
Prospect
 
mighty mouse's Avatar
 
Join Date: Apr 2014
Location: pittsburgh pa
Posts: 26
Thanks for the advice. On way home I checked and misfire was on 3. Counts were 148. Not enough to set the cel just save a pending code. I will try swapping injectors 1st later in the week. thanks again for the input every body. i just gotta drive for MPG not MPH.

---------- Post added at 03:52 PM ---------- Previous post was at 03:29 PM ----------

Just to recap. swapped coil 3 to 4. Misfire stayed on 3. Not always p0303. Sometimes p0300 n cylinders 1 and 4 would have the highest misses. but usually its p0303. Cel flashes then goes out. No CEL on. It shows a pending code n after a drive or 2 gone. when driven in old man mode n checking mis fire counts every thing normal. Thanks again for the input from every body on the forum.
mighty mouse is offline  
post #9 of 22 (permalink) Old 04-23-2014, 05:54 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
You're probably running out of fuel at high rpm. Fuel filter or maybe even fuel pump.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #10 of 22 (permalink) Old 04-23-2014, 08:33 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
I just replaced my fuel pump because I was running out of fuel up top. Not a hard job. Fuel filter is easy and cheap. Try that too

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome