I Was Driving Today And... - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-19-2014, 06:56 PM Thread Starter
Initiate
 
09ChevyCobalt's Avatar
 
Join Date: Apr 2014
Location: Freeville, Ny
Posts: 44
Garage
I Was Driving Today And...

my car felt very bogged down, like it was hesitating to get up to speed. i usually travel around 60mph in most of my area, today accelerating to 60 it felt very slow and i instantly felt the hesitation. what could be the reason for this?
its a 2009 ls i got it from the dealership a few months ago ive driven it 2300 miles i take very good care of my car because its like my kid lmao, im always checking my fluids and i have an oil change in 600 miles, could that really be the reason? or should i go ahead and do my plugs aswell, my air filter is a brand new factory filter.

oh there's 53000 total miles on the car single owner before me.


2009 cobalt ls~ white hubcaps/cobalt tag/front bowtie (Rear bowtie removed).

Last edited by 09ChevyCobalt; 05-19-2014 at 07:03 PM.
09ChevyCobalt is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-19-2014, 07:58 PM
Super Moderator


 
Plain Jane's Avatar
 
Join Date: Mar 2013
Location: Montreal, Quebec
Posts: 3,860
Garage
Got a CEL?

'07 Eclipse GT build thread - 280whp, 254wtq
Plain Jane is offline  
post #3 of 7 (permalink) Old 05-19-2014, 08:13 PM Thread Starter
Initiate
 
09ChevyCobalt's Avatar
 
Join Date: Apr 2014
Location: Freeville, Ny
Posts: 44
Garage
no lights on the dash at all. ive never had a warning light come on, not even for gas lol.


2009 cobalt ls~ white hubcaps/cobalt tag/front bowtie (Rear bowtie removed).
09ChevyCobalt is offline  
 
post #4 of 7 (permalink) Old 05-19-2014, 08:26 PM
Contributor
 
FloodKillaz's Avatar
 
Join Date: Mar 2014
Location: Lancaster, Pa
Posts: 278
Garage
Plugs are 100k mile plugs, but anything can happen along the way. I would change them. Check your fuel filter as well.

2010 Cobalt LT K&N TYPHOON INTAKE
2004 Cavalier LS clone
2003 Saturn L200 Fully loaded-Sold
1987 Toyota Celica
FloodKillaz is offline  
post #5 of 7 (permalink) Old 05-20-2014, 04:26 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Could just be bad gas.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #6 of 7 (permalink) Old 05-20-2014, 08:53 AM
Super Moderator


 
Plain Jane's Avatar
 
Join Date: Mar 2013
Location: Montreal, Quebec
Posts: 3,860
Garage
Happened to my sister's V6 Sonata. Filled up at a Chevron in upstate NY. Car limped home the whole way, surging and bogging. The poor thing kept stalling while we were in line at the boarder.

'07 Eclipse GT build thread - 280whp, 254wtq
Plain Jane is offline  
post #7 of 7 (permalink) Old 05-20-2014, 01:19 PM
Super Moderator
 
swanman35's Avatar
 
Join Date: May 2013
Location: SWPA
Posts: 2,068
Yeah maybe put some HEAT in your tank. It is supposed to remove any water if you have some in your gas

Sent from AutoGuide.com Free App
swanman35 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome