Car Revs Itself. - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 05-26-2014, 06:45 PM Thread Starter
Newcomer
 
Join Date: May 2014
Posts: 3
Car Revs Itself.

I have an 09 Cobalt 2.2 lt. While I'm driving 30-40 mph, the cars revs itself. its tuned up minus the fuel filter.
Regetony is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 05-26-2014, 07:56 PM
Prospect
 
KurtisHand's Avatar
 
Join Date: Jan 2013
Location: Franklin Maine
Posts: 14
Garage
Yeah I also have the 2.2. Mine does that too. Do you have an automatic?
KurtisHand is offline  
post #3 of 10 (permalink) Old 05-26-2014, 10:27 PM
Super Moderator


 
Plain Jane's Avatar
 
Join Date: Mar 2013
Location: Montreal, Quebec
Posts: 3,860
Garage
Does the transmission downshift? Do the rpms bounce around? Surge? Lug?

'07 Eclipse GT build thread - 280whp, 254wtq
Plain Jane is offline  
 
post #4 of 10 (permalink) Old 05-26-2014, 11:20 PM Thread Starter
Newcomer
 
Join Date: May 2014
Posts: 3
Yeah its an automatic.

---------- Post added at 10:20 PM ---------- Previous post was at 10:19 PM ----------

The rpms bounce. no downshift that im aware of.
Regetony is offline  
post #5 of 10 (permalink) Old 05-27-2014, 09:47 PM
Forum Regular
 
Join Date: Oct 2013
Posts: 84
Garage
i have an 07 Ls manual with the 2.2 and the other day I started mine and it revved itself up a few times for a time frame of about 10 seconds between 1 to 1.5k rpms but after that it was fine and drove fine with no other rpm problems, it has happened 1 other time after that the same day but it hasn't since
silverbullet67 is offline  
post #6 of 10 (permalink) Old 05-27-2014, 10:28 PM Thread Starter
Newcomer
 
Join Date: May 2014
Posts: 3
Quote:
Originally Posted by silverbullet67 View Post
i have an 07 Ls manual with the 2.2 and the other day I started mine and it revved itself up a few times for a time frame of about 10 seconds between 1 to 1.5k rpms but after that it was fine and drove fine with no other rpm problems, it has happened 1 other time after that the same day but it hasn't since
Mine does it all the time. Its annoying especially driving in the city.
Regetony is offline  
post #7 of 10 (permalink) Old 06-05-2014, 06:32 PM
Prospect
 
Join Date: Dec 2012
Posts: 15
I had that problem with mine. Also, it would die when I was turning or even at an idle sometimes. I cleaned the throtle body really good and it hasn't done it since.
Leonidas_2006 is offline  
post #8 of 10 (permalink) Old 06-06-2014, 08:57 AM
Cobalt Specialist
 
JacksonWilder3's Avatar
 
Join Date: May 2012
Location: Wasilla, Alaska
Posts: 1,067
Clean your MAF sensor, also clean your TB.
both take a couple of minutes...


2010 Cobalt 2LT Sports Package
2.5% tint all the way round.
SUPRRAAACHARRRGGEDDD
2.9 pulley, 60# Injectors, Injen 2.5" intake
55 Watt 6000K Hi/Lo HID's
35 Watt 5000K Fogs
Black SS 17" Wheels
Debadged
Spyder 3" Carbon Fiber Antenna
YAKIMA ROOF RACK WITH 40" LIGHTBAR
2.5' ZZP DP
Full set of Black Recaros
Eibach sportlines for teh low.
Front and rear SS lips
JacksonWilder3 is offline  
post #9 of 10 (permalink) Old 06-19-2014, 07:48 AM
Prospect
 
Join Date: Jun 2014
Posts: 10
Have cleaned throttle body and problem still comes back but only when it is below freezing....
iamn0angel is offline  
post #10 of 10 (permalink) Old 06-21-2014, 05:40 PM
Initiate
 
09ChevyCobalt's Avatar
 
Join Date: Apr 2014
Location: Freeville, Ny
Posts: 44
Garage
mine does this as well at slower speeds i wonder what it could be every day on my way to work because i go through two 30 mph zones a 15 mph school zone and a 35 mph zone, and i have no idea what it could be.


2009 cobalt ls~ white hubcaps/cobalt tag/front bowtie (Rear bowtie removed).
09ChevyCobalt is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome