Engine shakes at stop - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 06-10-2014, 03:15 PM Thread Starter
Forum Regular
 
Jmac23's Avatar
 
Join Date: Oct 2013
Posts: 111
Engine shakes at stop

Hey guys .. So its not about a cobalt but I'd rather want to hear your opinion ! My gf has a 2007 Toyota Camry with 140k .. The damn thing has given all sorts of problems ! Every time she comes to a stop the engine vibrates and shakes the whole car ! The idle is okay .. Doesn't want to die but could it be motor mounts ? And it shakes worse when the a/c is on .. Thanks guys

Sent from AutoGuide.com Free App
Jmac23 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-10-2014, 03:19 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Same as a Cobalt, they are notorious for dirty throttle body. Clean throttle body and MAF. If RPMs stay high at idle look at replacing both intake gaskets. The one between the throttle body and intake and the one between the intake and head if it's a 4 cylinder.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly

Last edited by Coby7; 06-11-2014 at 10:38 AM.
Coby7 is offline  
post #3 of 8 (permalink) Old 06-10-2014, 10:14 PM
YourCobalt of the Month WinnerForum God


 
Join Date: Oct 2012
Location: Clarence, NY- Buffalo suburbs
Posts: 2,036
Mine does that too, AC loads the engine more so more vibrations. I have transmission mounts that do it though. Has to be the mounts somewhere, jack it up and look at all of them it'll be easy to see if they're broken.

2009 Cobalt LS XFE (F23) Victory Red
YYZ V.3 Springs, Koni shocks/struts, Powell XXX rear swaybar, Brembo brake swap, 5 lug conversion, Ion Redline wheels, SS/SC interior swap including power conversion, K&N intake, Trifecta tune, Ark Performance N-II catback, Ark shorty antenna, SS body kit, Powell F23 rotated mount, LNF rear mount, Powell CABs
Soon to come- EFR 6758 turbo kit and make Retro Headlights.
andrewcarr1993 is offline  
 
post #4 of 8 (permalink) Old 06-10-2014, 11:44 PM
Super Moderator
 
swanman35's Avatar
 
Join Date: May 2013
Location: SWPA
Posts: 2,068
Yeah my cobalt is a bit shaky. I suspect the mounts cause when I put it In neutral it goes away

Sent from AutoGuide.com Free App
swanman35 is offline  
post #5 of 8 (permalink) Old 06-11-2014, 03:38 AM
Contributor
 
Iceman62's Avatar
 
Join Date: Jan 2014
Location: Eastern NE
Posts: 340
Years ago, while driving our family trickster (aka mini-van), I'd hear clunking when we cornered to the Left. Ended up being one of the motor mounts (broken). Definitely look at all the mounting points closely...good luck!

06 Cobalt LS (for my daughter)
MSgt, USAF (Retired)
Iceman62 is offline  
post #6 of 8 (permalink) Old 06-11-2014, 12:35 PM Thread Starter
Forum Regular
 
Jmac23's Avatar
 
Join Date: Oct 2013
Posts: 111
Yea ... My cobalt shakes as well when the ac is on but I only have 50k? Would it be time already to start changing mounts ? And my gf car needs the top mount for sure ! I just saw a small crack so I'm sure the rubber is already super dry

Sent from AutoGuide.com Free App
Jmac23 is offline  
post #7 of 8 (permalink) Old 06-11-2014, 12:51 PM
Contributor
 
keegs's Avatar
 
Join Date: Apr 2010
Posts: 311
Quote:
Originally Posted by Jmac23 View Post
Hey guys .. So its not about a cobalt but I'd rather want to hear your opinion ! My gf has a 2007 Toyota Camry with 140k .. The damn thing has given all sorts of problems ! Every time she comes to a stop the engine vibrates and shakes the whole car ! The idle is okay .. Doesn't want to die but could it be motor mounts ? And it shakes worse when the a/c is on .. Thanks guys

Sent from AutoGuide.com Free App
I had a problem with the engine shaking at idle about a year ago. I took the car to the dealer and they cleaned the injectors and told me to dump a can of Techron into the gas tank. Everything was fine for a day or so and I began to notice a slight shaking again so I dumped in another can of Techron and it was fine after that. Must have picked up a load of bad gas.

2010 Cobalt XFE
2006 Chevy Colorado 4x4
2005 Toyota Corolla
2013 Kubota M5640 SUD
keegs is offline  
post #8 of 8 (permalink) Old 06-11-2014, 05:46 PM
Forum Regular
 
Join Date: Jan 2011
Posts: 127
Not to be the bearer of bad news but my car had a shaking at stop, and it was a misfire/timing issue. New timing chain tensioner and timing chain for me.

Sent from AutoGuide.com Free App

---------- Post added at 06:46 PM ---------- Previous post was at 06:45 PM ----------

And mine wasnt misfire = new timing chain. Im not sure what happened in between but it was an escalating issue(s) for me.

Sent from AutoGuide.com Free App
teri2280 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome