P0418 Code After Tranny Install - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 1Likes
  • 1 Post By shifty2006
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-28-2015, 08:08 PM Thread Starter
Prospect
 
Join Date: Jun 2014
Location: Lake Isabella
Posts: 19
P0418 Code After Tranny Install

Noticed the air hose was disconnected at the bottom of the motor coming from the air cleaner assembly before the tranny swap no idea how many months so I made sure it was put on after the install but now the car keeps throwing the p0418 and I can't find too much on that exact code never had it before
JoeK likes this.
shifty2006 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 11-12-2015, 12:52 PM Thread Starter
Prospect
 
Join Date: Jun 2014
Location: Lake Isabella
Posts: 19
Before i just start throwing parts at this no one has any ideas of how to test this type of thing for the secondary air pump check engine light?
shifty2006 is offline  
post #3 of 7 (permalink) Old 11-12-2015, 01:12 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
P0418 Secondary Air Injection System Relay ‘A" Circuit Malfunction . That's pretty much it. Somedody on here already went through that hell. If you search you might fall on his thread. I think he ended up changing the pump.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
 
post #4 of 7 (permalink) Old 11-14-2015, 04:53 PM Thread Starter
Prospect
 
Join Date: Jun 2014
Location: Lake Isabella
Posts: 19
Is there a way aka which wire off the pump could I put 12v to with a jumper to see if it engages
shifty2006 is offline  
post #5 of 7 (permalink) Old 11-25-2015, 02:21 PM Thread Starter
Prospect
 
Join Date: Jun 2014
Location: Lake Isabella
Posts: 19
I have changed the pump and relay and the light is still on..
shifty2006 is offline  
post #6 of 7 (permalink) Old 11-25-2015, 03:05 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage



Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #7 of 7 (permalink) Old 12-03-2015, 08:40 PM Thread Starter
Prospect
 
Join Date: Jun 2014
Location: Lake Isabella
Posts: 19
Ok well I seem to have it figured out. The code isn't for the pump it's self but the circuit that controls it. So incase anyone gets this code I'll post what to do a short version. First is go to pin 14 on the larger plug of the ecu and back probe turn on the key then tap the wire on a grounding surface that should engage the pump if not check the 40 amp fuse that is for the pump and check the relay if both check out then open the fuse block on the lower left (closest to the front of the car and the passengerside) of the fuse plug you will see a brown wire (the same brown wire from the ecu test the wire from both ends make sure it isn't broke. Then check the pin that slides into said brown wire from the fuse block make sure it's not bent or corroded like mine was. Anyway I hope that make sense check fuse check relay back probe pin 14 on the ecu 72 pin connector turn the key to on ground it if it doesn't turn the pump on check the brown wire from ecu pin 14 to pin c2 of plug 1 on the fuse block and inspect pins for corrosion.
shifty2006 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome