No Start - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-07-2016, 07:58 AM Thread Starter
Newcomer
 
Join Date: Aug 2015
Posts: 4
No Start

Car has been in storage since november. For the first month of storage, I would start it up and drive it around the storage facility just to keep it moving around. but ever since mid December I havent been able to get the car to start. Turn the ignition on, ABS light and Traction Control light stay on. Go to start the engine and nothing happens. I get a click coming from underneath the dash (near the BCM) but the engine does not turn over.

My first suspicion was the battery. Checked the voltage, it was low at 11.69. Pulled the battery out and charged it at home. was able to charge it to about 12.6 volts. Put the battery back in the car, with no success. Had the battery load tested. Still put out 594 CCA's.

Every fuse was changed in the car this past summer. No idea what to check at this point. I'm considering pulling out the fuse box today and making sure nothing is loose, and checking for any corroded contacts.

Any ideas?
ricklovin93 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-07-2016, 10:49 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
You're on the right track. I would remove the boost post and clean all contacts under it then re-install.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome