07 Cobalt LS Won't Turn Over - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-23-2016, 01:06 PM Thread Starter
Newcomer
 
Join Date: Mar 2016
Posts: 2
07 Cobalt LS Won't Turn Over

Hi All. Since my ignition switch was replaced about 2 years ago, I've never had an issue w/my cobalt.....until today. Took my son to school, car started and ran perfectly. Come out of the school to head home and car is doing nothing. When you turn the key, the radio, lights will work, but it just makes 1 click then nothing. All fuses have been checked and we have tried to jump it, still nothing. Ended up having it towed home. Any suggestions?
minc3 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-23-2016, 01:28 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Did you check the big fuse in the trunk? Or maybe your starter went for a crap. Maybe the ground strap on the starter broke from rust and corrosion. Could be a lot of things start eliminating. Do you only have one GM?

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly

Last edited by Coby7; 03-23-2016 at 01:31 PM.
Coby7 is offline  
post #3 of 4 (permalink) Old 03-23-2016, 02:08 PM Thread Starter
Newcomer
 
Join Date: Mar 2016
Posts: 2
Only 1 GM. Fuse in trunk is fine. Checked it before attempting to jump it.

---------- Post added at 04:08 PM ---------- Previous post was at 04:07 PM ----------

After all the "idiot lights" have gone out, the only one left on is the check engine one.
minc3 is offline  
 
post #4 of 4 (permalink) Old 03-23-2016, 02:09 PM
Expert
 
Parthros's Avatar
 
Join Date: May 2015
Location: Oklahoma
Posts: 945
Garage
Next step would probably be to see if the ground strap on the starter is broken like Coby mentioned.


Since you've got a CEL, you might try reading the codes to see if it helps. If you can somehow get it to Autozone, they'll read codes for free, otherwise, a cheap scanner can be had for like $15 on Amazon.


Quote:
Originally Posted by Plain Jane View Post
Believe me, these cars have a habit of growing on their owners. Your feelings will only strengthen over time...
Parthros is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome