2 Issues with 2008 Cobalt Sport 4 Door - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-13-2016, 06:42 PM Thread Starter
Newcomer
 
Join Date: Jun 2016
Posts: 5
2 Issues with 2008 Cobalt Sport 4 Door

hi there,
we bought for my daughter a 2006 cobalt sport 4door.
the car had some little issues so we got it pretty cheap.
right now i am a little bit fighting with the power locks. when you sit inside the car, and push the lock or unlock button on either the driver or passenger door, you hear it clicking but nothing unlocks or locks.
i have the suspicion that it might be the driver side lock but i am not 100% sure, and i just don't wanna throw parts into it. cause my daughter is buying the parts.
second problem what i have is with the subwoofer. the subwoofer is not working. i am thinking that there must be somewhere an amp for the subwoofer, but i can't find it. maybe someone can help me with that too?

to my background, i am a master mechanic with 20 years experience.
thank you so much
daywalker is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-14-2016, 06:33 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Amplifier is near the steering column and has a separate fuse from the radio. Do the door locks work with the remote or when you put it in drive?

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 7 (permalink) Old 06-14-2016, 07:10 AM Thread Starter
Newcomer
 
Join Date: Jun 2016
Posts: 5
Ok I will test the amp tonight, I don't have a remote. I also don't think it locked when I put it in drive.
daywalker is offline  
 
post #4 of 7 (permalink) Old 06-15-2016, 04:46 AM Thread Starter
Newcomer
 
Join Date: Jun 2016
Posts: 5
ok tested it yesterday, it will klick when i put it in drive and also klicks when i put it back in park.
but the knobs does not move and os the doors do not unlock or lock.
other question, how do i get the amp out of the bracket, is there a special trick??
daywalker is offline  
post #5 of 7 (permalink) Old 06-15-2016, 05:32 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
The signal going to the door lock actuator comes from the BCM. You might have dirty contacts preventing could voltage to reach the doors. Try re-seating the 2 blue connectors on the BCM ''P1''.


Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #6 of 7 (permalink) Old 06-15-2016, 08:20 AM Thread Starter
Newcomer
 
Join Date: Jun 2016
Posts: 5
i will try this tonight, thank you so fare! any idears with the amp? how is it mouted? i saw three slots but almost impossible to get the upper screw out.
daywalker is offline  
post #7 of 7 (permalink) Old 06-16-2016, 09:56 AM Thread Starter
Newcomer
 
Join Date: Jun 2016
Posts: 5
so I took yesterday both connectors off and put them back into the controller, nothing. no change. I also disconnected first the passenger side (the door lock switch) and the driver side. also no result.
still everything is clicking when you press the switch or when you put it in park/drive. it almost seems like that the rods are sticking but I have almost all panels off so they can't stick.
anybody else other ideas??
daywalker is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome