07 Intermittent Electrical Problems? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-14-2016, 08:04 AM Thread Starter
Prospect
 
Join Date: Jul 2016
Posts: 10
07 Intermittent Electrical Problems?

Hi. Looking for some guidance with my 07 Cobalt that has 57,000 miles on it. My first incident was I went to start my car and the exterior lights stayed on until it killed the battery and needed recharged. After that four times it hasn't started and I go through the passcode lock sequence and then it will start. Twice when I got to work, I turned the key off and the engine kept running without the key. I drove it around for awhile and then it would turn off. Sometimes I have gauge lights and sometimes I don't. I had it put on a scanner twice and nothing showed up. I have a new battery in it. Anyone else have the same thing occur or any ideas of what is wrong with it? Not ready to give my car up yet
Thanks in advance for any help you can give me!!

Jo
jodeutsch is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-14-2016, 09:17 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Sounds like a bad ignition switch, I assume you had the recall done.... All of the stuff you mention is controlled by the BCM. Try pulling the connectors off the BCM and reseating them good. May or may not help but worth a try and cost nothing. Maybe add dielectric grease while you're at it to keep moisture out.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 4 (permalink) Old 07-14-2016, 09:27 AM Thread Starter
Prospect
 
Join Date: Jul 2016
Posts: 10
Hi Coby, I did have the ignition switch recall done. I will reseat the BCM connectors and see if that helps. Thanks so much for your quick reply and help....much appreciated!! Have a nice day! Jo
jodeutsch is offline  
 
post #4 of 4 (permalink) Old 07-14-2016, 09:37 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Maybe plug an un-plug a few times to clean corrosion if any and improve contact surface.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome