Throttle Position Sensor - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-11-2016, 04:34 PM Thread Starter
Prospect
 
Join Date: Jul 2015
Posts: 28
Throttle Position Sensor

I have a 2007 Chevy Cobalt. I drove it to work today with no problems. When I cranked it up this evening to go home the service light came on. I stopped by Auto Zone and the guy said my throttle position sensor was the problem. I searched online at Auto Zone, Advance Auto, Oreilys and a few other parts store but can't find the sensor. I read somewhere that the throttle body has to be replaced instead of replacing the sensor itself, is this so? The car is still running perfect and doesn't appear to have any trouble except the service light is on. Is there a test I can perform to determine the sensor is actually bad? I haven't checked for loose wires or anything yet because I wanted to get this posted asap to give everyone more time to respond while i'm looking because I need to use the car again tomorrow. Like I said earlier,it's running good "now" but don't know how long before the problem gets worse. Any advice???
Poppie51 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-11-2016, 07:08 PM
Cobalt Master
 
rrob5382's Avatar
 
Join Date: Apr 2013
Location: MI
Posts: 1,518
The throttle body is all electronic and everything is internal so I'd it is bad you need to swap throttle bodies, with that said there are ways to test it I'm sure but I don't know how. Someone else will probably chime in though. One thing you could try is checking if it's dirty and needs to be cleaned, don't know if that causes it to throw that code but they are prone to getting dirty.

---------- Post added at 10:08 PM ---------- Previous post was at 10:07 PM ----------

Just unhook the battery before you go messing with the throttle body at all
rrob5382 is offline  
post #3 of 8 (permalink) Old 08-12-2016, 02:59 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
What was the code? Because it could also be the pedal position sensor.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
 
post #4 of 8 (permalink) Old 08-12-2016, 08:36 AM
Expert
 
Parthros's Avatar
 
Join Date: May 2015
Location: Oklahoma
Posts: 945
Garage
Quote:
Originally Posted by rrob5382 View Post
The throttle body is all electronic and everything is internal so I'd it is bad you need to swap throttle bodies, with that said there are ways to test it I'm sure but I don't know how. Someone else will probably chime in though. One thing you could try is checking if it's dirty and needs to be cleaned, don't know if that causes it to throw that code but they are prone to getting dirty.

---------- Post added at 10:08 PM ---------- Previous post was at 10:07 PM ----------

Just unhook the battery before you go messing with the throttle body at all
Or just unplug the throttle body.


Quote:
Originally Posted by Plain Jane View Post
Believe me, these cars have a habit of growing on their owners. Your feelings will only strengthen over time...
Parthros is offline  
post #5 of 8 (permalink) Old 08-13-2016, 11:58 AM Thread Starter
Prospect
 
Join Date: Jul 2015
Posts: 28
Thanks rrob5382, Coby7, and Parthors for responding. I'm not sure of the code,the guy at Auto Zone connected his computer to the car then told me the throttle position sensor was bad. Would moisture affect this sensor? As stated earlier the light was not on while I was going to work. Ten hours later,when leaving work the light came on as soon as the car started. It has been raining almost everyday and although I had not driven anywhere,so therefore I did not hit any puddles of water to splash up around the engine,there is a lot of moisture in the air. The light stayed on until I got home,which is about 20 miles. The next morning when I started the car, the light was off and hasn't came back on yet. The vehicle has been running great even while the light was on so since the light has gone off should I go with the theory, " if it's not broke don't fix it," or is this a warning sign that I should not ignore? Thanks
Poppie51 is offline  
post #6 of 8 (permalink) Old 08-13-2016, 01:44 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
I would wait until the code comes back if it does. Then record the actual code if you want us to help.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #7 of 8 (permalink) Old 08-13-2016, 01:49 PM
Cobalt Master
 
rrob5382's Avatar
 
Join Date: Apr 2013
Location: MI
Posts: 1,518
It's impossible to diagnose a problem with zero symptoms, if it's not giving you any kind of trouble just let it be.
rrob5382 is offline  
post #8 of 8 (permalink) Old 08-13-2016, 03:47 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Plus the code might have just been a glitch. A piece of dirt on one of the 2 wipers either on the throttle position sensor or the gas pedal position sensor.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome