Recurring Noise from Oxygen Sensor? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-16-2016, 07:44 PM Thread Starter
Veteran
 
GpB311's Avatar
 
Join Date: Jun 2010
Location: Los Angeles, CA
Posts: 713
Garage
Recurring Noise from Oxygen Sensor?

I put my badmab header back on and noticed the O2 sensor was all bent out of shape somehow. I replaced it with the proper ac delco part, but now I am getting this weird noise from that area/rear of the engine. Maybe its not related, but ive never heard this noise before. Im at 125,000 miles, so I suppose it could be worse.

Any of you recognize the noise? Sometimes it doesnt happen at all, sometimes it starts and then stops after a few minutes, other times it never stops.


GpB311 Showoff Profile https://www.yourcobalt.com/forums/veh...ngeles-ca.html


You might also know me as Dick Thrusthumper...
GpB311 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-17-2016, 06:26 AM
Expert
 
Parthros's Avatar
 
Join Date: May 2015
Location: Oklahoma
Posts: 945
Garage
I wonder if the header also got a bit bent out of shape, and now a non-bent O2 sensor doesn't quite fit which causes that weird whistling?


Quote:
Originally Posted by Plain Jane View Post
Believe me, these cars have a habit of growing on their owners. Your feelings will only strengthen over time...
Parthros is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome