2010 Cobalt Ss/tc Boost Problem - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-12-2016, 09:14 AM Thread Starter
Newcomer
 
Join Date: Oct 2016
Posts: 1
2010 Cobalt Ss/tc Boost Problem

My 2010 cobalt sstc is having problems. i switched from the trifecta 91 tune to the trifecta E47 tune. my car is kinda sluggish, it wont let me build any boost after i drive down the highway for about 5 minutes, but boosts fine in town. i was throwing a MAf performance code so i replaced the maf and still having issues. i now through a cyllinder miss fire in 1 & 3. the RPMs will hold or decrese very slowly after i let off throttle. Is this all tune related??
2010ssHunter is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-12-2016, 11:22 AM
Expert
 
Parthros's Avatar
 
Join Date: May 2015
Location: Oklahoma
Posts: 945
Garage
Sounds like probably a tune issue. You are running E47 though, right? Not still running 91 on the new tune?


Quote:
Originally Posted by Plain Jane View Post
Believe me, these cars have a habit of growing on their owners. Your feelings will only strengthen over time...
Parthros is offline  
Sponsored Links
Advertisement
 
Closed Thread

Tags
2010 , lnf , no boost

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome